Testing problem

I finished the building and are testing, but that goes not well.
When i use your test file, the logo, from the site i get a mesh.
Half way the print the z axis goes up to change postion and after that it comes not down enough to the bed and is whriting in the air.
Allready flipped the connector from the motors but that is no solution.
The axes turn the same way as my 3D printer. Knob to the right on the x motor goes right.
Knob to the right on the y and the motor goes away from my.
I load the file in Repetier eand save it for SD. Repetier printer type is CNC router.
I use the Marlin version you have changed for the 8 mm spindle.
Have you any idea what i do wrong ?
In Marlin i changde the endstops setting for optical stops and that is working fine.
Printing direct from Repetier does not work it connects but no reaction on the mpcnc.
Running on Windows 10

Edit removed the endstops. Still no good print.

  1. Did you buy everything from here? no ( i live in Hollond and bying oversea’s bring to much tax about 25 % minimum.)
    a)If you didn’t or changed some things please don’t leave out any details. No
    b)What firmware? 8mm spindle form the site here.

  2. Are you using end stops? Yes opic
    a)If so please disconnect them. OK
    b) If the problem is still there leave them disconnected while troubleshooting.

  3. Are you using all my recommended parts? Yes exsept the end stops
    a) If not please list what parts you used.
    b) I am not against other peoples parts but most of them have not actually even been tested on a working machine. I am against people making “improved” parts when they have not even tried mine. Please, “don’t fix what ain’t broke”.

  4. Include a picture so obvious errors might be spotted send a email with a picture.

Try it again at 50% feedrate. It sounds like a z speed issue.

Picture didn’t show up.

Since you aren’t using my stuff, are you using ramps, what drivers, what step rate, what size steppers, what voltage are you driving them with?

I use a mega 250 with 1.4 ramp 32 steppers driver DRV8825 on 1.7 volt
Endstops are removed.
Result :


I set the feedrate to 50 % and now its is working.
Got a good drawing now. Not level but the drawing line is as is must be.
Thanks for the help.


Because you are using the 8mmm rod you need to decrease your z axis feed speed or change that axis to 16th stepping and change the feeds and accel accordingly.

Can you gif me the correct settings ?
I am a beginner on CNC and Repetier.
For 3D printing i use Cura and that i understand.

Have a other problem. When i set the z by “move axis down” the machine goes up again after starting the print and prints in the air.
As i do the same by hand and turn the power on then it works fine.

I don’t have an 8mm rod to test, The 8mm firmware I was sure took care of it. Try slowly increasing the feedrate. I’m sure you can go faster than 50%. No one else has had a problem with the 8mm so maybe your machine is just tight and needs to break in.

You can use cura, no problem.

When you get the nozzle at the build plate, or 0,0,0, make sure the position reads 0,0,0. if not reset the arduino or hit set home offsets on the LCD.

Thanks for you reaction.
I don’t use the mpcnc for 3d printing it will be for milling and plotting, cutting things.
Plotting goes fine now so i will leave it as it is.
The 0,0,0 home offset i will do tomorrow now it is time to go to bed here.
Cura does not see the .gco only the .gcode
Is there a trick for ?