The port COM1 does not exsist


I’m new to the MPCNC world and am asking for help. I purchased the ramps board/driver/mega package from here (vicious), have a psu all configured and ready to go, installed repetier host on two different computers, but cannot get the host to connect and talk to my board.

I was dedicating an old laptop to my MPCNC machine and couldn’t get it connected, so I brought the board to my main computer where I am running a Printrbot Simple Metal with Cura controlling it to see if it was a laptop issue, but I keep getting the same message: “The connection failed with the following error: The port COM1 does not exisit. Make sure your printer is connected, enabled and connection data is set correct. Open printer settings?” I am probably doing something really bonehead, but cannot figure it out, so I’m asking for your help.

This forum has been a myriad of help to me and I’ve always been able to figure out what my issue is by searching and reading. Thank you in advance.

Are you sure that COM1 is what is being assigned to the Mega? There are two things you could check here:

  1. Open the device manager (with the board plugged in), and check the Ports section to see if you can see the Arduino Mega. Check what COM was assigned.
  2. With the Mega plugged in, open the Arduino IDE and select the Mega board and see if it auto detects it from there.

You mentioned that you had installed Repetier Host, did you also install Repetier Server? R-Server could be controlling the port and not allowing access from anything else. If this is the case, kill the process in the task manager and try reconnecting in Repetier Host.


Thanks for your help, I am now able to talk to the board and have it recognized by repetier host.

I am not using this board at a 3d printer, only cnc mill, so I have no thermostat hooked up, therefore I have installed a 100K ohm resistor to the “T0” on the board per the assembly instructions. I am trying to make sure motors are working and pots set correctly, but am unable to have any manual control over the board. I keep getting a new error message telling me “extruder switched off. MAXTEMP triggered!” and then after that an Error code of: “Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)”

I have googled the above and tried a myriad of different tweaks, but to no avail. If I’m missing something easy (more than likely the problem), if someone could point out my bonehead mistake, I’ll keep pressing on.

Thanks again for everyone’s help with my issue.


Did you change the firmware, it should work as is? The resistor should stop the maxtemp error, are you sure it is making a connection?

Firmware was not changed or altered. It still shows the firmware that you installed on Jan 21, 2016 with your name as author, before you shipped.

I will check the resistor to make sure it is making a connection. I just soldered it straight to the T0. Still got an over temp.

I think I just figured it out. I’m using 1/4W resistors, so I put a 200k Ohm on and it worked. Now testing all my motors, board is active.

Thanks for all your help everyone.

I’m also having an issue with COM Port. The Repetier host only gives me options for a virtual port, and bluetooth. I looked on the arduino and seems that’s where the problem lies…
ports listed are:


Anyone have the firmware in a sketch?

That resistor will work fine.

Just to clarify to any reading this, 100K Ohm is what is specified.

You are on a MAC, Things are different you can google repetier and mac settings.

Here is what I know. Try installing arduino’s software first to get the right drivers, then you will need to edit the firmware with a lower baud rate setting. One that will match what shows up in repetier on your mac, 115200 I believe.

Just to follow up on this, I didn’t change the firmware from the board I bought from Vicious. It took quite a while to search and find the correct drivers, but that was the issue with my board. I’m running Windows 7 home on the old laptop I’ve dedicated to this project. I’m up and running and drawing sketches with a pen while I plan my next move of mounting a cutting tool.

Hello Bryan,

I am also having the same issue, I read your steps but this is outside of my comfort zone and not sure how to get all of this to work.

I have a Rambo 1.4 (purchased from V1) all my motors and endstops are connected. Board is powered (Green indicator light is on, no other indicator lights on or flashing), and USB connected to computer. Repeater software is saying the COM 1 port not detected. I went to the ports section and it shows a USB to COM 3.

I do not know how to do anything in Arduino.

1 Like

I found where to change the Connection Port in Repeater to COM 3 and its working!!