TMC Connection Error on SKR1.2

So i’m trying to set everything up for my first CNC machine. I plug everything into the SKR 1.2 i ordered, and so far i’ve had no luck controlling anything. I see a TMC Connection Error on the LCD.

I’ve tried plugging in the motors and removing them, same error.
I’ve tried removing every driver and starting, still the same error.
I’ve checked every pin on the board (a similar instance was reported on the forum with a bent pin touching)
I’ve checked all the fuses, no visible issue.
I’ve checked all the jumpers and setup matches the images on the website ( referencing https://www.v1engineering.com/wp-content/uploads/2020/07/Dual-Ex-1-scaled.jpg)
I’ve checked the black cable to the LCD has the single pin connected and on the correct side.

I’m not sure what else i should be checking at this point. I haven’t installed new firmware yet as i’d like to get it working before customizing anything.

Here is what i have. If you need photos of specific areas i can take better ones.


Those photos show the problem. Thanks for posting them.

You need to also connect the 12V to the units labeled “MOTOR”. That should fix it.

TheTMC connection error means Marlin can’t talk to theTMC drivers (because they don’t have power).

Yup, that was it. Easy enough. I’m no longer getting an error and the motors move, but i’m still having problems with the end stops.
I used the default firmware, then moved to the dual endstop firmware, but when i try to home it never recognizes the endstops. The switches are set up as NC, that seems to be what is expected though the guides don’t explicitly say.

I’m using Marlin_V1CNC_SkrPro_Dual_2209_2.0.9.2_513-src.zip

Before trying to home, check with M119. You can use the terminal on the LCD.

Make sure you see the X2 and Y2 min endstops.

Make sure the correct endstop says triggered when you press it.

Make sure they are all open when none of the switches are pressed.

You should be able to narrow it down. It is usually a loose wire, or sometimes having the X1 and X2 switches swapped.