Track code in Repetier

I’m using vcarve desktop and repetier with the skr pro board. I ran a fairly long project the other day and on the finishing pass it seems a line of code was skipped. There was one pass that wasn’t cut. Is there a way to have repetier show the code as it sends it? That way I could recut that section if needed. Or are there other suggestions on how to find that particular line of gcode?

@jamiek does your octoprint cnc viewer plugin allow to live view the assiociated gcode on each move ?

I have not watched to see if it works, but it is strucurally unchanged from the original, so it should work as well as the original.

Note that with CNC the command queue can seem deeper than with 3D printing, since long movements are more common. This means the “live” view may lag, potentially by a lot if your job has long movements.

If you are just looking for that line, and you know what part of the job did not get done, you could use any of the online g-code simulators and simply cut the file up until you found the line(s) for the cutting you missed. I’ve used this simulator in the past, mostly because it was the first search hit, and I know there are others. Just copy and paste in your g-code file, and then start deleting chunks until you isolate the problem line(s). For doing your recutting, you may need more context than just the line(s) you isolate.

Edit: Finding the line might also tell you why it happened…look for things like unsupported g-code commands, bad line endings, etc. While it is unlikely, we have seen a few instances on the forum of electronic noise corrupted the g-code being sent.

I’m not using octoprint but I probably need to.

I’ve had that happen with marlin reading gcode off usb stick. Out of habit now i break larger more detailed operations into several seperate programs. Rare if there is an issue, or at least less to re-run. Come to think of it, don’t remember seeing the issue since I removed the micro sd card. Read somewhere that leaving it in can cause an issue.

1 Like

I’m connecting via usb directly from my laptop, so I’m not using an SD card. The finishing pass was a one pass operation separate from the roughing pass.

I meant the micro sd card used for flashing firmware. Read it causes issues if left in skrpro board. Haven’t had an issue since, if remembering correctly. I use usb stick plugged into tft screen.

Gotcha. I did remove the sd card after I flashed the firmware.

I’m not sure where you are with your original problem. I don’t remember ever reading about a similar problem on the forum, but this afternoon, something similar happened to me. A chunk of my path was just not cut. My g-code was created by Lightburn. When I zoomed in Lightburn to the corner that was not cut, I found a tiny loop in the path. I removed the loop, and the second cut went fine. I wished I’d save the file to figure out if it was a Lightburn bug or a Marlin bug. I suspect Marlin. This may not be the root of your problem, but I wanted to mention it.

Thanks Robert. I’ve been out of town and haven’t tried anything else yet. I was cutting poplar as a trial before I cut the expensive mesquite. I’ll try again tomorrow.

I suspect it may be a marlin thing. The last time i saw the issue, two of the same pieces were run back to back. One missed a spot to cut, while the other ran 100%. It was the same gcode file, run twice. Just my two cents…


I’m going to try it again tomorrow. Hopefully it’s just a one time glitch. It’s frustrating because it was really my first real 2.5d cut and it was going so well.