Trouble focusing 3W laser

I just received my 3W laser from china and I am hoping someone out there can help me with the focusing. Every time I think that I have it close, I start the job and it barely makes a dent at 100% power. As you can see from the attachment there is this larger blue circle around the center burn area.

The other strange issue is that when focusing the beam you can nudge the side of the lense (it is slightly wobbly) and the focus dot changes resolution. Sometimes tighter focus, sometimes worse.

Anyone run into any issues like these before?

Maybe the lens came loose in the housing?

I took it back off of the machine for another inspection. the focusing threading is what seems to be loose. When I thread the lense on I can hold the housing and the dial and it wiggles at the thread level. Could this be because the spring is to short and it isn’t pushing out enough? anything I could put on the threads to try and stiffen it up?

I was thinking of getting some thread tape to try and tighten it up without making it permanent.

[attachment file=38000]

[attachment file=38001]

some people use pipe tape to snug it up a bit, and/or stretch the spring a bit.

So the tape did the trick for snugging it all up and focusing. thank you for the advice

New issue is settings and tricks for 3dpBurner Image2Gcode (MPCNC)
At MAX output I am getting a decent burn i would have thought it should be darker. I have reduced the gamma setting and slowed down to 1000 mm/m but it still seems to light.

If I use the laseretch program supplied by JTech I get a MUCH deeper pronounced burn. I know I am only using the sample version with limitations but I still like the 3dbBurner better.

Anyone have any idea how full power on each program can be so different?

Look at the gcode and see if it is using all 255 of the pwm.

yes it is using all of them.

The weird part of this is when I first started up the later I used 3dpBurner and it was so high it just left a black square. I just deleted the settings folder in appdata and regenerated a picture with max setting and 1000 feed. Will test and update tomorrow.

OK so the issue definitely seems to be with how I am using 3dpBurner-i2gc

Laseretch,, both burn at high intensity completely burning the board to a crisp.

I tried the demo of piclaser which at 100% just left a black square and had to back it off to 90 before i started to some real variation.

I found the 1.1 version of 3dpBurner-i2gc but at 100% power it barely leaves the markings. I have slowed down to 800mm/m but that is far slower than the other programs so I dont understand what is happening.

What version is everyone else using?

Any idea why the intensity doesn’t seem to work?

Can you put up some screenshots of your settings.

here are my i2gc settings.



not wishing to highjack this thread but having finally got my laser working with the Inkscape plugin clearly the next thing to try is img2gcode. I’ve read all 266 posts in the thread on the “software” page of the forum but can somebody confirm the URL to download the program. I’ve found one which delivers an .exe file so I assume if that is correct I would just “double click” or setup a link to that and it would run. I will of course be interested in the answer to the question John Warren posted yesterday regarding his settings as somewhere to start would be helpful


John the setting look good the only thing I can think of is the picture is not super dark and not triggering a 255 in the gcode, but you said you are getting a m106 s255. If the gcode says that then it makes zero sense you are not burning a hole in the wood.

Dennis I will try and link the latest exe in the first post, there are a few versions some were a bit custom for people. The latest should be fine. I rarely use that I most use the inkscape plugin for vector stuff.


I’ve downloaded the image2gcode V1.1 from the URL in the post by Jason on 19 Jan 2017 (#25421) w. The program runs, in the about tab the changelog goes upto v6. However when importing a .png image of a rectangle the image does display on the image tab and the other settings are similar to everybody else’s (including Jason’s mirror thread) but the generated gcode never turns the laser on after the original M106 S5 for drawing the box. The only other M106 S commands are in the extract of the gcode below.

I haven’t actually put it on the MPCNC, at the moment I’m just looking at the gcode in Notepad++. I’m unclear if I’ve picked up a non working zip or something else, any thoughts.


(Generated by 3dpBurner Image2Gcode v1.1)
(@Jul/20/2017 19:47:20)

G0 X0 Y0
(Header end)



G0 Y9.859155; Move to top left corner and begin box
G92 X0 Y9.859155

M106 S5
G0 X100
G0 Y0
G0 X0

G0 X0 Y9.9
M106 S0
G1 X0 G1 Y9.72
M106 S0
G1 X0.18
G1 X0.36
G1 X0.54
G1 X0.72
G1 X0.9
G1 X1.08
G1 X1.26
G1 X1.44

I just tried to different version, and you are right I am not getting any m106 commands after the first two. I have no idea what is going on. Let me get the rest of the orders out and try to look into this a bit. I tried a jpg and a png.

A few notes here,

You are moving too fast at too high of a resolution.

Sorry I was wrong jpg and bmp do seem to work, PNG does not. At least a png with a transparent background does not.

Now why didn’t I think of that? Taking my sample 3 box gray scale .PNG file (produced as export from Inkscape) into MS Paint (i.e. the program included with Windows) and than saving it as a .JPG file now produces M106 commands with S values. In doing the conversion Paint warns that the file will lose transparency information. I understand about the speed and resolution I just wanted to get gcode looking sensible in an editor before I committed to firing up the laser.

I wonder if image2gcode can’t cope with .PNG files or if it’s something specific either to inkscape produced files or to the transparency state, certainly the windows photos app just displays a black screen so my file clearly has issues.

Thanks as ever for your help