Trouble on "layershift"

When i cut out a square that is 50x50 mm the machine acts great.

But if i do a cutout on 600mm x 600mm the first pass seems to do good, next run it for sure have missed some steps. and it goes worse and worse.
Iam not sure what this could be. when i let the machine go without the spindle it will do the whole gcode without any hickups.

i have tried different speeds etc.



More details please. Zip and include your Gcode. It is usually speeds 99% of the time but you haven’t given any other information to go off of. Build pics, bit, spindle, material, size, diameter, rapids vs cutting?

Ok here is some info, the gcode is from aspire, i used the file number 5 seems to work on the minor things. like the 50x50mm square that is made right before i tryed the 600mmx 600mm cutout.

I have tried 50mm/sec with 3mm cut, and i think the last one is 25mm/sec 2mm cut.

Could it be stepperdrivers that is to hot? and miss steps?

Its a ramps 1.4 with the recomended stepperdrivers and the recomended voltage on the steppers. followed the instructions on the build.

Material trying to cut is ordinary plywood.
its a 4mm 2 flute bit. (590 Bytes)

Your Z rapids are too fast, as are your cuts. 50mm/s in not recommended.

Here you have the tool section. is it the plunge rate that is to high then ?

is it this that sets the rapid speed ? G1 Z5.080 F500


For the Z stay under 10mm/s, and make sure your rapids follow this as well, currently yours do not.

will this make the z go 10mm/s

from the gcode

; 600600cutout_z10mms
; Safe Z height: 5.080
; Tools: 1 = End Mill (4 mm)
; Notes:
; Generated Thursday September 13 2018 09:28 PM

M84 S0
M03 S12000
G00 X0.000 Y0.000 Z0.000
G1 Z5.080 F100
G1 X0.000 Y0.000 F1500.0

; Tool 1: End Mill (4 mm)
; Path: Profile 1 C:\Users\Svein Inge\Documents\600600cutout_z10mms.gcode
G0 X2.000 Y2.000 Z5.080 F3000.0
G1 Z-1.857 F600.0
G1 X292.000 F1500.0
G1 X308.000 F1500.0
G1 X598.000 F1500.0
G1 Y292.000 F1500.0
G1 Y308.000 F1500.0
G1 Y598.000 F1500.0
G1 X308.000 F1500.0
G1 X292.000 F1500.0
G1 X2.000 F1500.0
G1 Y308.000 F1500.0


Okay wait, I jumped the gun, I should not make blanket statements. What leadscrew are you using, what steppers, drivers, control board, firmware, and step rate?

Have you tried using my crown gcode with great results?

Here is the crown with your ready made gcode.

I will say thats about perfect .

Firmware is the one found on your page, I have a t8 lead screw in my setup. and I use the firmware for T8 screw


Okay, then your new settings should work. If you still have issues slow the X rapids down some more.

Iam using 8825 stepperdrivers, Ramps 1.4 controller.

So my latest gcode will work fine then, this has now z-rapid 10mm/s ?

600600cutout_z10mms.gcode (2.78 KB)