UGS Connecting

Hello, showing CONNECTING in the DRO, and [MSG:Reset to continue] on the Console, but all commands are grayed out.
Only alternative is connect/disconnect button but again same messsages.
Any help is more than welcome.

Using GRBL1.1
UGS 2.0.12
UNO original
Arduino Shield V3

Do you have the correct baud rate and serial port selected? If I remember correctly, I had to change it from the default when I was trying a similar setup.

yes I did it, correct port and baud 115200.

1 Like

You have to send a $X to unlock GRBL

1 Like

Agree, but it is grayed out. I can not input.

What version of GRBL are you running? Sorry missed the first post. Did you reset the grbl board ?has it worked in the past?

To diagnose if this is UGS vs something else, you can try using a basic terminal program to read boot up messages if any, and send a reset to see how it responds. If that seems to work well, then it’s definitely a problem with ug

Yes I did, install GBRL and UGS again, it works if I don’t tick the end stops and homing. But when homing only home X and Y, axis Z does not move. Thanks for the reply

Terminal from windows? Where can I find how to do it? It is new for me.

I have never used homing. So i will not be able to help much i use hard stops and a touch plate. I use the hard stops to square the x y. Then use aluminum tape and the probe module and set the x and y edge then probe the z hight for each tool change

1 Like

No worries thanks anyway, I want to make the zeroing if you have info about that would be precious. Thanks

UGS greys out the command line (and other functions) until it can communicate with a valid GRBL. When you connect to the board do you see the list of current settings in the console window or just a

**** Connected to COM12 @ 115200 baud **** ?

If you don’t see -

Grbl 1.1f ['$' for help]
>>> $$
$0 = 10    (Step pulse time, microseconds)
$1 = 25    (Step idle delay, milliseconds)
$2 = 0    (Step pulse invert, mask)
$3 = 0    (Step direction invert, mask)
$4 = 0    (Invert step enable pin, boolean)
$5 = 0    (Invert limit pins, boolean)
$6 = 0    (Invert probe pin, boolean)
$10 = 1    (Status report options, mask)
$11 = 0.010    (Junction deviation, millimeters)
$12 = 0.002    (Arc tolerance, millimeters)
$13 = 0    (Report in inches, boolean)
$20 = 0    (Soft limits enable, boolean)
$21 = 0    (Hard limits enable, boolean)
$22 = 1    (Homing cycle enable, boolean)
$23 = 3    (Homing direction invert, mask)
$24 = 500.000    (Homing locate feed rate, mm/min)
$25 = 3000.000    (Homing search seek rate, mm/min)
$26 = 250    (Homing switch debounce delay, milliseconds)
$27 = 5.000    (Homing switch pull-off distance, millimeters)
$30 = 1000    (Maximum spindle speed, RPM)
$31 = 0    (Minimum spindle speed, RPM)
$32 = 0    (Laser-mode enable, boolean)
$100 = 80.000    (X-axis travel resolution, step/mm)
$101 = 80.000    (Y-axis travel resolution, step/mm)
$102 = 425.000    (Z-axis travel resolution, step/mm)
$110 = 3000.000    (X-axis maximum rate, mm/min)
$111 = 3000.000    (Y-axis maximum rate, mm/min)
$112 = 500.000    (Z-axis maximum rate, mm/min)
$120 = 100.000    (X-axis acceleration, mm/sec^2)
$121 = 100.000    (Y-axis acceleration, mm/sec^2)
$122 = 10.000    (Z-axis acceleration, mm/sec^2)
$130 = 270.000    (X-axis maximum travel, millimeters)
$131 = 270.000    (Y-axis maximum travel, millimeters)
$132 = 35.000    (Z-axis maximum travel, millimeters)

…or similar, it is not a valid copy of GRBL.

I see you enable HOME but not stop limits, how can I home without stop limits? Is it too elementary question? Sorry

That print out is not from a ‘live’ uno board - just an uno I flashed to get the screenshot.

Soft limits requires homing to be enabled but not the other way around. see GRBL github for more info.

Those settings would allow homing (at the start of a job for example) but if you commanded the carriages either over or under the physical limits it would try to get there. The problem with hard limits is once the switch is activated you have to physically move the carriage off the limit switch and soft limits are not needed unless you screwup the size of the job or forget to enter your home position (something you cant do if you ‘home’ the m/c first). I think you will pretty soon find limit switching to be a PITA. It is not like the average laser m/c will self destruct if a carriage hits a hard stop.

2 Likes

I also struggled with this once in a while, I now realize that it only happens when I connect the arduino to wrong usb. Now i marked the one i should use, just so i dont jave to memorize which is what, all i need to remember is where port 6 is :slight_smile:

I would try another the other ports, or maybe go through the set up of us again and remember what port you used while doing this. That’s what I did in the end :slight_smile:

Ugs does not use exactly the same commands. I get an error like $ not recognized. You have to go into firmware via wifi to configure motor configuration changes. Then you just connect. Things should work. I haven’t configured mine yet, because I need to figure it out the mm per cycle. Startout doing the travel for mm distance before you doing any other changes, because if you change the number of cycles will change the distance movement figures.