v1pi: Raspberry Pi Image with Octoprint and CNC.js (and wifi hotspot)

Here are some great instructions for it on the v1pi:

I’m using stock CNC js.

I don’t have a reason to have both octoprint and cncjs on the same pi as my machines are all over the shop. Plus I have full wifi in the shop, so no need to hotspot.

1 Like

If you’re running it on a pi, the instructions should be close to the same. Just find your config file and point it to the code you downloaded.

There is a docker image for cncjs. I have considered changing to that instead of managing the services using linux. The main reason I went with the octopi image is because it sets up the pi well. I would have to look through the fixes they have amd recreate them in a cncjs only image.

1 Like

I thought about trying all this pendant stuff, but found so much easier to just launch and connect another instance of CNC.js on my mini iPad. And it’s truly wireless. All commands and my custom commands available. Works good enough for me.

I think the phone sized interface doesn’t have the same room. And it can be tricky when it is sized for keyboards and mice. But it is definitely good that you found your way.

Yes, the sizing is a bit quirky, but not too bad, I’m making it work. It’s even better on my larger work iPad.

1 Like

I typically just connect to the cnc.js from the shop laptop. It’s not horrible. I carry the laptop over to the machine and put it on a bench for jogging/etc. Then once I start the process I can walk away. It’d be nice to have some type of screen at the machine to glance at to see where the job is at. The ETA on cnc.js is kinda wonky, so I’m not really sure what all I’d want to see. For the longer laser burns I’ve been doing, I can usually just look at the picture and see how far it’s gone.

Actually, now that I think about it I’m not sure what/why I was thinking I needed a pendant. I think it just looked cool.

I’ll pretend I didn’t just read that… Even if later context implies that it’s for laser work.

You can pretend all you want. The truth is, I have too much going on to sit there and stare at a machine doing the work I tell it to do.

It’s not like I leave the shop. It’s always in ear shot and you can hear when it bogs down. I also have an E-stop on the front of the machine that kills the entire system if needed.


That’s what I like to read. Very different from just “walking away”. More like “stepping over to work on something else in the shop”. :smiley:

Safety is one thing I don’t think we can be too cavalier about. And I’ll be the first to admit that part of my “safety police” attitude/behavior is to ensure that it’s ingrained into my own head, and that I don’t fall into the trap of thinking I’m in control, or that I know that the machine will be fine while I pop out (in?) to warm up my coffee.

So I got all this working with my setup, and love it. My question is… The SKR Boards allow for a USB file drop to the SD card instead of a “firmware flash”. Is there a way to have the Octoprint or the CNC.js access the SD card for the same purpose, just dropping a file. That way we can compile, drop it on the SKR SD card, and reset the board? Thoughts? Not sure if that is above everyone’s paygrade here, but … Perhaps that would be cool…

I was half-assed trying to do this today. I think the firmware updater plugin can do it, but there is a specific configuration needed on the skr for it to work first. Something related to the sd set to ONBOARD. Have you flashed it already by mounting the card over USB?

Ya, it works great when connected to the pc, platform.io/vs code just writes right to the card, then you reset the board and away it goes.

Hi everibody !
i think i will go crazy trying to resolved my problem i explain !

i have !

LowRider2 CNC 4x8 install

Longruner Écran tactile 7" pour Raspberry Pi 1024 x 600 Écran LCD HDMI avec étui de protection et support

Labists Raspberry Pi 4 Kit de démarrage 4GB

Vaorwne Rambo 1.4 Carte mère Rambo V1.4 Méga et pas à pas à pas pour imprimante 3D Lulzbot Taz6

and i went to the reference site to plug it !

i download the version 17.1 whit hotspot also tried whitout hotspot and both i cant see in the display longruner screen but from my pc i have access i dont now where to find the configuration to help me to connect everiting to work fine i now people have a external screen attach to the PI4 and conect via usb to the rambo 1.4 but i cant do it !

Please help me before i go crazi !


Francois from montréal quebec canada

Thanks for this solution! I was having the same issue and now it works great!

Greetings Francois,

The V1pi does not include a graphical “desktop” evironment. It is intended to be accessed and utilized via a network. It sounds like your system is working as it should.

It is possible to add the necessary components to have a touchscreen interface.

This has been described previously in this thread

I hope that helps.

I will look to it thanks

I downloaded the vipi image (no hotspot) from github, edited the landing page to fix the CNC.js port and it isn’t showing me /dev/ttyUSB0 as an option as a port to connect to. I only see /dev/ttyAMA0 (which isn’t even an option in /dev/ (but lets me connect, so ??)

Any hints?

What was wrong with the CNC.js port?

Is the control board connected to the pi, and is it on? It should show up after it is connected.

/dev/ttyAMA0 is the builtin serial on the GPIO pins, I think.

Mine wasn’t pointing to 8000, but rather 5080 Detailed here

Re: tty stuff, I’m a moron. Was logged in to the wrong host when checking /dev/ and the USB cable was indeed unplugged… Got the crown printed out w/ CNC.js so all is good.

1 Like