v1pi: Raspberry Pi Image with Octoprint and CNC.js (and wifi hotspot)

Are you connecting locally? Like with a screen on the same pi, or remotely, from a different computer?

I’m connecting from another computer (shell access and web browser). I was able to print the crown, as I said, but things were a bit herky jerky compared to the SD Card.

Curious as my CNC is a mess right now after building a bed for my daughter and I can’t get to it, but does the version of CNCjs on the current version of the v1pi include the X and Y probe capability?

I haven’t used those features. CNCjs just interfaces to Marlin though, so if Marlin can handle it, you can at least do the macros to measure it. I don’t know what you do after that though.

I just did some checking. It’s cncjs version 1.19.22 that has the feature. That’s in the beta 0.17.1. I’m going to test that one out.

I’m not using Marlin on my LowRider. I switched to grbl and have had many less problems.

1 Like

Hello, I managed to get everything set up (Raspberry pi 3b+, no hotspot connecting to the full rambo board), but I am encountering an issue any time I attempt to send a manual move command, the OK seems to be being missed every time.

The “dip a toe in” page mentions this is a know issue, and there is a fix,

**CNC.js currently has a tiny issue ” There’s an issue with a timeout failing, and the ‘ok’ getting missed. There is a solution to commenting out a line, and there’s a github issue for it. The workaround is to send some other command in the terminal window, which will send another ‘ok’. I just send G1 X0.”

While the entering of another command technically works, having to do it every movement makes cnc.js significantly less useful. I can’t for the life of me discover any additional information about the github issue or the supposed comment fix. Anyone able to point me to more information?

I had that problem. I updated to the latest cncjs and reflashed Marlin. I’m not sure which fixed it.

Is the Pi Zero W still working well for you with Octoprint and CNC.js? I am thinking of putting that on my cantilever laser engraver so it does not take as much room on the back of the machine and be less expensive. Looks like I have 1 usb connection on the Pi Zero W to connect to the keystudio Grbl board.

Goodness… many moons and machines ago. I’ve used my little Pi ZeroW and CNC.js (not Octoprint) on numerous machines as I was building, testing, and using them… TimSav, R&P MPCNC, TimSavX2 hot-wire, etc. I don’t recall ever having problems with Pi ZeroW for the simple stuff I was doing… until I tried to do fancier stuff like camera timelapse, etc. It did it… it was just a bit sluggish doing it. I also used a USB expander/converter gadget I got somewhere to expand the number of USB ports and provide full-size USB interface. Here I was using it on R&P MPCNC…

I’d suggest just trying it. If it doesn’t work as well or as fast as you’d like you can always put the same microSD card into a Pi 3B+ and keep on truckin’…

I have one on my mp3dp and it does work. It is noticeably slower and I’m not sure how future proof it will be. The price difference is a little misleading too, because you need a power supply and usb otg cable to make it work. But it really should work.

I have a spare pi zero W, but not a spare Pi which is why I was considering this. Looks like either https://www.adafruit.com/product/2910 or https://www.adafruit.com/product/2991 will work with the zero. I will be connecting it to a nano on the keystudio board which appears to be a mini usb connection. Maybe I will just order a Pi 4 to replace on my main 3d printer & use that pi 3B+, but seems like I would need better heat dissipation with the pi 4.

1 Like

The pi 4 works great, but it also needs a usb c power adaptor. So unless you have an extra, that is another purchase.

Oh yea, I forgot they switched to usb c power. I would have had to buy a P/S for it anyway. How are you cooling yours, or did you need to use a fan or big passive heatsink?

I have a few pi4s. Some have a fan and some have a heatsink case. FWIW, they protect themselves if they overheat, they just slow way down. So it isn’t critical that you have cooling, just gives you more bang for the buck. The pi3B+ seems to not need it.

Thanks for the info. I just ordered a pi4 w/2gb and P/S from www.pishop.us with a couple their 3 pack small heatsinks & will see how that does with the heat. I had read the heatsink case can interfere with the WiFi signal, so I didn’t get one of those for now. Do you have any WiFi problems with your heatsink case?

Upgrading to the PRIMO has been a great opportunity to upgrade electronics as well. I’ve now got v1pi running on a RPI 3B+. I’ve got a few questions:
I got the “forbidden access” error, and changed the landingpage to direct to port 8000. Why is this error happening? It’s not a big deal, as long as pointing directly towards 8000 is okay.

Octoprint and/or cncjs. Does these two services impact each other in any way? I’m used to cnc.js, and don’t see why I would need octoprint. I’m thinking of disabling it, but I wonder if there something to octoprint I’m missing out on? (I do love it for my printer!)

Do people get their power from the USB connection to the Rambo? From what I can see at Ultimaker, the Rambo is not supposed to deliver power over USB at all. I’m planning to use a step down-unit and convert 12v from the power supply to 5v.

I don’t know. I suspect it is an issue with the browser demanding an https connection, along with the fact I don’t have the CA to do https correctly. But I haven’t been able to reproduce it here.

Only one can connect at a time. They are both pretty easy to manage when nothing is connected. I don’t bother disabling mine, but it won’t hurt if you do.

The rambo will only power the USB chip from the usb, not the whole board.

For the pi?

1 Like

Thanks for your quick reply!

The same error happens when I write the url by hand and no “s”.

I meant the other way - if the Rambo usb can deliver power to the pi. I’m settled for, since I will have 5v from the step down.

Im sorry for being ignorant - What do you use octoprint for, printing only, or cnc’ing as well?

I installed it on the image mostly because it was already there :). But there’s no reason you can’t use it for milling. I do use the v1 pi image on my printers, just to get more hours on the image. I feel a little better when someone has trouble with cncjs that there is octoprint there anyway.

1 Like

Hi Jeffeb3!


Thanks for all your contributions!
Can you please check the link is returning a 404. Nonetheless, i was able to get the camera working by configuring the url on the Webcam widget as: http://AAA.BBB.CCC.DDD:4080/webcam/?action=stream&680193 if that helps anybody.