Vetric Advice - Post Processor Not Working

Does it plunge straight to that depth? Or does it go down progressively? When you move the z axis up or down by say, 5mm, does it move the actual 5mm? Or more?

I don’t think this is a gcode problem. But can you go ahead and post the gcode?


I think you need to take a step back. Run some code generated by Fusion 360. I would be looking at loose couplers, stepper motor connections loose, etc. Since you haven’t had the machine running for long it’s quite possible something just worked loose, especially since you said it seems to get worse each attempt. Do you have miniRambo, rambo?

My z was loosing steps because my acme screw and nut were bent and too tight i swapped it for a piece of scrap that was straight and got a good carve out! Yay! I know what im ordering today…





It’s always some little thing that screws us up. I had my connectors backward, you had the bent piece. Apparently, Mr. Murphy is having a very good time messing with us.

1 Like

I got a new acme threaded rod and nut. Does anyone use this (i got 2):

Anti Backlash Spring Loaded Nut Elimination Gap Nut for 8mm Acme Threaded Rod

I don’t. That’s for the all-thread bolt? Cool. That would take up that small amount of slack in there. Where’d you get it?


I got it from amazon. Its for an acme thread rod:

We had a loooooot of issues in the beginning with anti-backlash nuts. Don’t really need them since there’s so much weight hanging on the z.

im using the 500w brushless spindle that weighs nothing, basically.

So question.

VCarve works with marlin? or do you need a specific post processor? (if so, link?)



So am I. Anti-backlash nuts aren’t needed for this. The only way you’ll get any resistance on the z is if you have the bearings too tight. Gravity is your friend in this instance.

Should be links in the software section of the instructions.

1 Like

You need a post processor for any machine if you’re using vcarve or aspire.

1 Like

Well, I tried to attach the post-processor file but it won’t let me.

Search for: Marlin_mm test5.pp

and there’s another

Marlin_mm test4.pp

5 works with my Aspire just fine. It will work for VCarve too.

1 Like

Now that I’m on a computer, and not my phone… All the way down at the bottom.

1 Like

Awesome appreciate it!

I guess because it says “what we have so far” I was under the impression the post processor for those weren’t complete (and I’m not that advanced to attempt to mess with it haha).


So im messing with Vcarve and I wanted to slightly slightly tweak the PP which ive never done before. I wanted it so that where I put the head on the material prior to starting is my x0,y0,z0 (using g92). And I also wanted to make it so that I have to click the LCD button to start the program (so I can turn on the router as my last step M0). I also wanted to disable the endstops as sometimes I start from the center of a part and ive wasted some nice oak by forgetting to manually turn them and the head never goes into the negative so I wanted to manually add in a M121.

Can you guys tell me if that what it should look like?

begin HEADER

“; Safe Z height: [SAFEZ]”
“; Tools: [TOOLS_USED]”
“; Notes: [FILE_NOTES]”
“; Generated [DATE] [TIME]”
" "
“M84 S0”
“M03 [S]”
“G92 X0.0 Y0.0 Z0.0”
“G00 X0.000 Y0.000 Z0.000”
“G1 Z[SAFEZ] F500”
“G1 [XH] [YH] [F]”
" "
“; Tool [T]: [TOOLNAME]”





Andddd im wondering if this is possible lol… Is there a way to make it so that I would choose my desired starting point for cutting by manually moving the head. Have it so that it homes X and Y and then goes back to the original start point I moved it to, then disables the endstops so I can cut from the negative. Not sure if I would gain any more accurate cuts on it by doing this as I feel like after homing you shouldnt be manually moving the head around as wouldnt that defeat the purpose?







I don’t think you need m121, the other two lines look okay. What happened when you tried it? Not very many people have that software around here so I wrote it but have not ever tried it.

So m21 was a typo lol. Because I have endstops I wanted to go negative and I meant to say M211 S0


So it didnt like the g92 which isnt necessary anyways. I am finding that my rapid is super slow but overall its working well. Here is the last thing I ran which was fine minus the slow rapids…

[attachment file=121425]

Sweetbabyjesus.gcode (75.8 KB)