What do I need to change in the firmware for this board?

I have a board called a mega controller. You can find it on the reprap wiki, this forum won’t let me link it. From what I understand, it’s the ramps 1.4 and the mega controller in one board. I also have A4988 stepper drivers. What will I have to change from the provided firmware to get this to work? I’m trying to build a 24" by 24" mpcnc without the endstops. I also have an lcd.

To post.links and other forum things

Get to trust level 1 by…
Entering at least 5 topics
Reading at least 30 posts
Spend a total of 10 minutes reading posts
Users at trust level 1 can…
Use all core Discourse functions; all new user restrictions are removed

Send PMs

Upload images and attachments if enabled

Edit wiki posts

Flag posts

Mute other users

ok thanks. Do you know what I would have to change in the firmware?

I do not sorry but there are several people here who will have a idea

Alrighty, thanks.

Welcome to the madhouse!

I’m guessing you could treat it like a Ramps 1.4 board. Make sure to set the drivers to A4988s, set the microstepping to 16 (max on the A4988), and be sure to get the steps/mm set right.

You can grab the V1 Rambo Dual source branch, and just change the motherboard. The Marlin defaults for the drivers and steps/mm are already fine for the A4988 and 16 microsteps.


So I just download the V1 Rambo Dual stuff from Github, change that in the code and it should work?

Yeah, I would think that will work. You will want to follow Ryan’s instructions on the firmware pages on how to compile and upload to your board.

And will this work with an LCD and SD card or no?

Depends on what kind of LCD you have. Ryan has all of his firmware setup to work with the larger LCD that he also sells in the store. If you have a different one then you would need to make some other changes.

Here is the one the firmware is setup for.

Looks pretty similar to mine, I’m loading it all on now connected to the lcd to see if it will work.

I tried uploading both the Rambo and Ramps firmware. The lcd is just blue. I don’t know if it is the lcd that isn’t working or more than that, as my mpcnc isn’t built yet to test.

Edit: I loaded up printrun, it seems the firmware is on there, I just have to get the lcd to work. I’m not sure what lcd it is but it has the sd card reader separate from it.

Could you upload a pic of the LCD please? That will help determine what advice I give next.

Standard troubleshooting for LCD issues is to plug the cables in both ways to both connectors. You won’t break anything, and the cables are often mis-wired. And yes, you are sometimes fighting the keyed connectors…

Can’t that fry the lcd?

Not if it’s one of the RepRap LCDs. Either the Full LCD (the big one) or the “Deluxe” one (the four-line one).

Yeah, that’s the big one that’s on by default in Ryan’s firmware. Obviously, you can’t swap one cable for the other… :man_facepalming: But flip it on the control boad.

It should work with RAMPS, not RAMBO.

I’m assuming it worked before? It looks kind of like the reprap full discount thing we use, but the sd card is separated funny. If it worked before, I doubt the cables need to be swapped.

Can you post a pic of the board with the lcd cables plugged in?

You will also need to adjust the steps/mm to 100,100,400 for the a4988.