What is this symptomatic of? (Extruder, z- stepper issue, or something else)

Hi All,

I’ve attached a picture that has 5 attempts to print a simple 1x1x1" hollow cube for calibration purposes. However, as you’ll see from the image, the extruder seems to be pushing PLA material that’s been extruded, which to me suggests that the extruder is not being moved up enough on the z-axis for a given layer. This seems to start out fairly early in the printing process and progressively gets worse as the height increases, as seen from left-to-right in the attached picture. This is occurring both on infill passes as well as perimeter passes.

I’m using the recommended slicer settings explained on this site, https://www.v1engineering.com/import-extruder. I have also tried placing the nozzle at different starting heights ranging from touching my heatbed to approximately 2 sheets of printer paper off of the bed, but it does not appear to make a difference. It may (or may not) also be worth noting that this behavior also occurs when I try to print the test part in the above URL

Clearly, something is off but I’ve run out of potential things to investigate. I would appreciate any suggestions on what might be causing the nozzle to hang too low.

Thank you.

These things should all be included in your post. It makes it much faster to diagnose problems.

  1. Did you buy everything from here?
    a)If you didn’t or changed some things please don’t leave out any details.
    b)What firmware?
  2. Are you using end stops?
    a)If so please disconnect them.
  3. Are you using all my recommended parts?
    a) If not please list what parts you used.
  4. Include a picture so obvious errors might be spotted.

Additional information that I failed to provide in initial post.

  1. everything was bought from this site
    1b) Firmware = B16_32-LCD-112515, I have not changed anything from the file provided via this site.
  2. no end stops in use
  3. All parts were purchased from this site and are in use.
  4. Provided in initial post

Are you using 1.75 mm filament? What brand and what temp? What is the difference in all those squares different start heights? Try something larger, and let it get much higher. if you are having start height issues they will go away a few mm up by themselves.

Do you have any other experience 3D printing? 3D printing is very difficult at first despite what some companies would have you think. There is even a video of the printrbot ceo saying exactly this. I/we can get you printing but please have patience. There are many many details to go over.

I’m not sure what the 2 sheet of paper thing is we start from contact, for us zero is zero no goofy offsets.

A picture of you full machine is the picture I am looking for. in this case of your extruder setup would be nice as well.

test file to see if it is a slicing issue (most likely)

test.zip (938 KB)

a) using 1.75 filament made by Hatchbox
b) I’m a complete newbie RE: 3d printing. This post isn’t meant to be a complaint as much as it is seeking for guidance on how to troubleshoot. I’m assuming this is all part of the tuning and calibration process, but not having done this before, I’m not sure on how best to troubleshoot.

c) pictures of extruder, general setup and failed test piece attached. Also included a picture to illustrate the approximate starting height of z-axis. If =

d) Tried printing your test file, but only made it to layer 21 before piece popped off of heated bed, which as set to 50 degrees C. I noticed the issue less, but it is still occurring, as seen on the corners of the 21-layer piece.

Thank you for your assistance.

Yikes. So it is not the gcode.

Do you have all three jumpers under the extruder driver? Did you set the driver voltage (.6-.7V)?

ATM x,y and z steppers are using DRV8825 drivers. Extruder driver in use currently A4988, but have some more DRV825 otw. All drivers have been confirmed to be running at .6V. All 3 jumpers under all 3 steppers and extruder drivers are connected.

There it is, the a49 is in 16th stepping mode. it is spitting out double the plastic.

(you didn’t get it all from me…)

You need to reflash the board and change the E steps to 100, instead of 200

Ah, OK. Would this also be remedied by replacing the A4988 with a DRV825 driver?

Thank you again for your assistance!

Yeah but you already have the a49 don’t bother switching. Might as well flash the RC8 firmware while your at it.

Had this same exact problem from using a A4988 extruder driver. Edited the config file and now working perfectly. Saved me some time, much thanks!