windows 10 and Mega 2560

I have an original kit purchased here with a Made in China ardunio mega 2560…windows 10 doesnt see it, doesnt make it an unknown device…im not sure what to do…tried installing china drivers, tried installing 340 and 341 drivers…

If you bought it from me, I test them and flash them on a windows 10 machine. Did you install arduino?

I did, I was probably one of your first customers when you started. Im just getting around to finishing my project. 2 Yellow lights on and a green light.


Hmmmm, easiest thing to try is pull the ramps shield off and see if you can flash the arduino naked. I got it on there so it should work with standard arduino drivers, I never sold boards with the outdated usb that needed funky drivers.

already pulled everything off. Its almost like the bootloader is fkd. I can see its the c340g chip so I know its a knock off. It doesnt even show in device manager as an unknown device. also took off my other com port assignment usb devices so there would be no chance for conflict.

I can tell you for certain I flashed it with regular drivers. That is odd. luckily a new “mega” is only a few bucks.

just tested with an arduino uno and uploaded a file. Its definitely the mega. Its not so much about another board which i cant source locally, its about my available time to do these things. I was hoping to actually fix it. With the lights coming on, its not really clear why its not working.

and I did go ahead and order another but this time I opted to avoid the ch chipset, so Im not asking for anything I just wanted to fix it if at all possible


I’m not sure why some people have a hard time getting them to connect. That is something I tried really hard to figure out. I took boards to friends houses and used fresh computers too flash them trying to find the issue so I could give a fix, but the only thing we found was some older MAC’s needed a slower baud rate.

yeh well i said fuck it and just through the damn thing in the trash