Wiring issues? or power supply? please help :)

  1. Did you buy everything from here? Nope :frowning:
    a)If you didn’t or changed some things please don’t leave out any details. (purchased all recommended items from your list)
    b)What firmware? Marlin_16_32_090615_therm
  2. Are you using end stops? no
  3. Are you using all my recommended parts? yes

So having a issue not sure if power supply or I have to wait for the jumpers to arrive for the cnc shield but seems when power to the cnc shield the power light only flickers on the brick I had to crack it open to make sure it was flickering seems power is getting to unit but will not kick in.

I have repetier host that I used so I know its connected to the software computer correctly used it since it was the same software I use for my 3d printer.

so based on my pictures and the info provided someone can lead me in the right direction, if its just a jumper issue I will be greatly awaiting their arrival.


Is your red wire really the negative?

ya I opened up the case as well and its labeled negative, and white is positive

I would check it with a multimeter, unplug it from the board and verify it says 12V+. I have that board but never assembled it, you should be able to verify the board is okay by flashing the chip.

You could have a bad power supply, not likely but one of the easiest things to test.

ok pulled off the board and its running 12.27v and light when up green when testing so going to go over the board and double check it. I am wondering if they miss printed the board as well, possibly red is positive will look into that more will pop open the power supply after as well.

So looks like the power was not as it was printed motor engaged this time can feel it tighten up now but still no control going on might be repetier host time to play some more

ok so I am getting somewhere now… but obviously missing something.

here is some more

I’m not sure repetier works with grbl. Did you flash your board yet or does it come pre-programmed?

I thought it was pre-programmed… going to have to load it up and check here as soon as I can.

If it didn’t come with jumpers I doubt the arduino was programmed.

Universal G-code Sender is what ill try out next as well. since I know that one will work

so after a bunch of talking with you and plotting out my next moves, I have made progress.

removed the arduino mega from the equation seems the windows xp machine I had the usb serial driver for it was a joke

hooked up my arduino uno sent the grbl firmware with xloader and it took both on boards btw
hooked up the sheild to it and loaded Universal G-code Sender and we have motion!

then I tried out a few other senders grblControl seems to be a nice one in my opinion so will play with that more.

onto the next step getting the rest of the motors hooked and ready to rock.

now I have a arduino mega for another project win win.

thanks for the help

Video of her first movement