x axis steppers randomly changing direction



I’ve finally set up the MPCNC and i’m having a really weird problem with the x axis stepper motors.

When I try to get the stepper motors to go in one direction, sometimes they do, sometimes they don’t, sometimes they just freeze (judder but move nowhere)

This does not appear to be based on travel speed.

When y and x are swapped on the ramps board, y works perfectly with either, x freaks out with either.

wiring is shown below.

it worked well enough to draw a small pen plotted butterfly earlier, so I don’t know what has changed (if anything).


so basics:

  1. Did you buy everything from here- No everything was bought elsewhere.

a)If you didn’t or changed some things please don’t leave out any details and include what firmware you flashed. - Stock firmware for ramps +LCD

  1. Are you using end stops?- No
    a)If so please disconnect them.

  2. Mac or PC? - PC,

  3. Include a picture so obvious errors might be spotted. - see below

wiring for the two motors

Google Photos

and a video of the control moving in only one direction:

<source src="https://goo.gl/photos/B7VoS5kzWVugyic9A" />


(in case it doesn’t load) and I can’t include it


Anywas I’m really stumped on this. any ideas anyone?




Correct step rate and driver voltage? You didn’t specify what you are using so I can only guess. Those pulleys are moving really fast so maybe you didn’t buy drv8825’s and got the a49’s instead…then you have to cut the step rate in half in the firmware. You need need to get specific when you didn’t buy it from here, steppers, step angle, rated voltage.


The wiring picture doesn’t help most steppers make up there own wiring scheme so not much anyone can do to help by color unless they have the same exact steppers.

1 Like

If one of your coils wasn’t connected, you’d get something like this. If it’s spinning fast, it just skips over the other coil. If it’s going slow, or stopped, then the direction would be random. Check the resistance across both your coils, and if do don’t see one that’s open, try it while moving the cables around.

1 Like

AHA! I think you are right,


The ramps kit includes the A4988 drivers:

and the steppers are spec’d as follows:

nufacturer Part Number 17HS19-2004S1
Step Angle 1.8°
Step Accuracy 5%
Holding Torque 59Ncm(83.6oz.in)
Rated Current/phase 2.0A
Phase Resistance 1.4ohms
Voltage 2.8V
Inductance 3.0mH±20%(1KHz)
Weight 400g

(I actually bought these to make a welded construction CNC, but saw the MPCNC and figured it was a better idea)


I will have to try halving the step rate in the firmware.


Thank you! I was really at a brick wall with this

That should do it.

If that does not help, please also check the wiring for any shorts or internal breaks as jeffeb3 mentioned. I built a delta printer a couple of years ago and made all of my own wiring. My extruder stepper was doing just this during testing. When I’d send a command for a long extrude move to feed filament into the bowden tube, it would move erratically in forward and reverse. Turned out it was an open connection on one of my splices. Re-soldered and sleeved the connections and it has been running fine for 2+ years.

1 Like



Hey guys thanks for the help.

Turns out one of the coils in one of the stepper motors had failed (come loose or something) replacing the stepper solved the problem. The firmware flash is still pending, but i’ll change that to ensure it is changed before the first cut ( I need to order a replacement stepper )