X Layer shift


Happens about every hour of printing. Always a 5-10mm shift in X, only happens on one layer, then back to ‘normal’.

Keen to iron this out, have eliminated anything mechanical, and been through two different ramps boards, and two sets of stepper drivers. The steppers are cooled while the printer is powered. The only thing I haven’t swapped out is the Arduino board, which I could do as I have a spare (for my MPCNC build :slight_smile:

I have ordered a 30A psu, as I think the 5A one that came with my printer might be pushed to the limit. 30A because I want to add a heated bed at some point.

The stepper drivers are drv8825’s. They are set up for microstepping - I am still not clear after reading loads whether disabling this might help with torque. They vref is set identically on all of them to give 1.7A to the steppers. I have 4 fans in total, probably taking about 500mA collectively, plus whatever the hotend is taking. Is 5A actually enough? I guees the e0 and z steppers are never at full tilt.

I am using Repetier Firmware 0.92. I had previously reduced jerk values from 20 down to 10, and that seemed to make it go away, but after a few good prints, it came back 30% into a 1.5hour print :frowning:

I have now reduced firmware x and y max acceleration from the stock 1000mm/s(2) down to 500. In my slicer config, travel rate is down from 130mm/s to 70, and I reduced the infill rate from 80mm/s to 70.

I get this both with printing straight from Repetier Host, and from SD card on the printer.

It has got me interested in logging the voltage on the X-stepper over time, and made me realise despite experience with voltmeters and scopes, I have no idea how to do this (would be cool to be able to graph the stepper voltage in realtime on a laptop screen).

Need to sort this out before I try to print the XY or XYZ parts!



What are you printing with?

a printer or the mpcnc?

Your stepper driver vales are way off, try .7V not 1.7V. You are probably going into thermal shutdown.

You speeds are kind oall over the place as well completely wrong if you are using the mpcnc, could be right for a printer.
Some pictures and more info would help.
What size steppers, why not repetier? If you are lost you should stick to the recommended build and software where all the info is already laid out including speeds and accelerations.

I am printing with an obscure ramps based 3d printer (Sumpod). I am trying to get to the point where I can print out the parts for the MPCNC.

Not 1.7V, 1.7A. The vrefs are 0.85v, which I understand sets the max current to 1.7A. I could try lowering that a bit, as it could well be thermal cut-out. I am doubtful of this, as there are two good fans on the driver heatsinks. Actually now I remember, I have had them running at 0.75V before and tried an increase. The steppers are running quiet and cool.

The speed changes I mention are all reductions I have made to the Repetier/Slicer defaults. I am using Repetier Firmware and host. I have used Marlin previously but couldn’t iron out the issue with that either.

The steppers are 1.7a nema 17’s (Wantai)


Something isn’t right. If you are running your drivers at .85v, and your steppers are rated at 1.7a (that is very large for a generic printer) the steppers should be very hot at least the x and Y.

The part looks decent, except the end error. Your layers look really thick, nozzle size, layer height? Your print speeds are high even for a well tuned printer. Just for kicks set all print speeds to 30mm/s infill, exterior, moves everything. you should also stick with some small calibration prints. 20-50mm cubes are good, then you can also check stepper calibration.

If you nozzle is a .4 use .26 for a layer height.

If that doesn’t work upload screen shots of your machine and all your settings and probably some gcode as well. You might want to see what value sunpod actually recommends, slow accelerations that you have will cause rounded corners and blobs.

Sumpod collapsed - they were a bit of a fail. Nice design though. The 19mm MDF frame actually allows some light milling, which is why I think it came with 1.7A steppers. I’ll have to re-check the vref and get back to you. The X and Y steppers are running fairly cool.

The print quality I’m getting is excellent - I have printed the pineapple knob, and many other parts beautifully. The nozzle is 0.4mm and the layer height is 0.3. For reference, the internal diameter of that circle is 15mm.

When I’ve been printing your MPCNC parts (small ones for now) I’ve adopted your layer and infill settings. All kinds of calibration objects are printing fine - cubes, bridges, overhangs, oozebane, etc. The issue shows up when printing large parts - In this case I’m making a new hotend mount, and curiously, that layer shift has happened twice at almost the identical point.

I’ll keep trying to ramp down the speeds - I had already started a new attempt with everything a bit lower, but if that fails I’ll try your speeds.

Some MPCNC parts I’ve done - all fine.

The print I started before your post about going to 30mm/s max was set to 45mm/s max. It also failed.

Seems like this part is a good stress test for my layer shift as it is consistently failing.

I’ll try 30mm/s tonight.

It could be an overhang issue, is the nozzle catching on a curling piece? either too hot of extrusion, or need to orient the piece to your print fan better.

No overhang curling issues here, I had that as part of my calibration phase, and indeed it was all in the fan placement.

Just tried the same print again, this time with a all at 30mm/s as you suggested. I got the same layer shift. This time it was slightly further than before at about 15mm displacement. It happens later in the print with the lower speeds so far.

I have measured the stepper drivers with an IR probe at 55c at around the time of failure. I couldn’t find a listed thermal shutdown temperature for DRV8824’s, but I’ve seen it for other drivers at 160c. The steppers are running at around 40c.

I’m about to re-calibrate the vrefs, but I’m not so sure it’s speed related now

Are you sure one of your pulleys isn’t just loose, or your gcode is screwed up, try a different slicer all together.

It’s a rack and pinion drive on X and Y. I have it pretty honed for lash and play.

I will add changing the slicer to the list of things to check, but would you not think that a problem with the gcode would show up in the same place each time?

I did get the vrefs looked at. I watched the vid from Polulu on your RAMPS section - I hadn’t realised that the DRV8824 is only rated to supply 1.5A at 12V, so all vrefs are now 0.7V.

I have a spare stepper as a next thing to try.

I believe the designer of my printer probably supplied the kit with 1.7A steppers because the construction requires some power. The bed moves in the x-plane, and is quite a bulky thing. Mine is well tuned and lubricated though. I suppose that’s why the steppers run so cool, the drivers are rated at below the current of the steppers.

Some Sumpod images

Just a thought (other than to ensure all the rods are very well lubricated) make sure your end stop wires do not go anywhere near the stepper motor wires, otherwise you will pick up crosstalk.

I think it was cross talk.

I made a change in Repetier firmware changing ALWAYS_CHECK_ENDSTOPS from 1 to 0. This means they’re only checked during homing. Of course this is not the solution. Instead I’m going to look at my end stop wire routing, and employ a bit of twisting and perhaps shielding.

I was able to print the part this time with no layer shift. Because I had the idea it wasn’t speed related, I tried pushing things a bit. My printer has steel rack and pinion drive, a very solid mdf frame and powerful steppers for the job. Basically it’s designed to be rigid enough for milling. After trying everything to get rid of the layer shift, I’ve got it super tuned now!

As it turns out, I could go back to all the defaults for acceleration, jerk and print speeds, and print fine. Finally I tried it at a 150% feed rate multiplier, and it printed fine with only a tiny loss in print quality. So travel of 195m/s and print speeds of 90m/s.

I had the same problem with my new MPCNC, but only when homing since that’s the only time I use end-stops. I think your wires must have moved enough for the cross-talk to appear when your Z axis moved down far enough. I’m glad you got your part printed! Good luck with all the others!

I am glad I was able to profit from your findings. I have been struggling with this one for a while.

Changing the speed did delay the effects of the issue, but at a given speed the it happened at similar times. I guess lower speeds mean lower current and lower cross talk.

I am finally confident in starting to print the big parts, so many thanks for helping!