Z-Axis dropping and stepper motor making strange noises

Hey everyone, me again with even more problems!
So I made some modifications to my table because I was having clearance issues (x-axis running into wheels) and when I got everything back together I tried to run a facing operation to level the spoilboard. Unfortunately, this happened:

It looks like my z-axis just dropped itself. Why would this happen? I tried to turn off and reset my RAMBo so everything was level again, and then one of my z-axis stepper motors started doing this:

I tried moving it up and down, and the motor would only move downward, causing my gantry to twist. I haven't heard of this issue or seen it before. Could this be caused by running grbl? I feel like a lot of my problems might be because I'm not using Marlin (I don't want to give up on grbl, but I really just want my machine to just work).

I don’t believe that grbl would be the problem. Lot’s of people run grbl. :slight_smile:

That’s fair. I just seem to be running into a lot of problems, and Marlin is the recommended firmware for the Lowrider afaik. I don’t think there’s really anything strange about my setup, but I keep running into problems.

I’m just getting frustrated with it, so I’m going to try Ryan’s Marlin firmware and see if I can get consistent cuts that way. If I can’t, I may just tear the whole thing apart and start over.

There is grbl setting in firmware that if not set correctly the motors will not stay energized. I accidently altered mine and had that problem.

I have $1=225, is that right?

Yes that is what it should be. Sorry should be 255.

no, $1=255 not 225.


Sorry, that was just me typing poorly.
I went a-googling and found a similar issue that was being caused by a loose wire. I pulled all my cabling out and checked all the connectors. It’s working fine now.
I also switched to Ryan’s Marlin firmware and made the changes I needed for the Lowrider. It seems to be working fine now, so I guess a connector just came loose. I’m going to give this a shot (assuming I can get pronterface to work and send a job) since it seems to be playing nice with me. It’s a bit sad, since I like grbl so much. But at the end of the day I have to use what cuts.

1 Like

It looked like a typo. I just pointed it out in case you made it while setting in grbl too :slight_smile:

Hahaha, thanks for looking out for me! I jumped back to grbl to see if I could figure out the firmware at all. I think I may have fixed homing, so we’ll see what happens tomorrow.