Z Axis goes down instead of up after work done at x=0, y=0 after update


I just redid my z-axis with a T8 and am loving it since then. With that, I updated the firmware to have the steps correct with the T8. My last firmware was uploaded in April 2017 when I finished the machine. There was really no need for an update since now.

Back with the old firmware, when the Job was done, the Z-Axis went up to 5mm above workpiece-zero, moved to x-zero, y-zero and stayed there.

Now the spindel goes up (might still be 5mm), than moves to x-zero, y-zero and goes down there into the workpiece (around 2mm).

Does anyone has an idea, what that could be? Any change that was made in the last year, that could bring that problem?


Thanks in advance,



It may be possible that with the T8 leadscrew that the weight of the spindle is just pulling the Z axis down after the stepper releases. My spindle will drop under its own weight because the T8 is so smooth. Try holding the spindle up after it moves to the X&Y 0 and see if it is really being driven by the Z axis stepper.

Mike is probably right. If you have any extras on there like vacuum or a cable chain, even more so. Much less friction and mechanical advantage now with a T8.

There is some ending gcode at the bottom of the LowRider page to help with that.

Ah, so the stepmotors get “turned off” when the job is done?

Unless you tell them otherwise, yes.

Jens. This same thing was occuring with mine when the router is running. Just need to add an enable stepper command to the end of your code. That cured it for me. It will also make sure you dont accidently bump the x or y off as well. I can’t remember off hand what that code is again. Its been a month or two since I last ran the machine and thats when I fixed it.

My steppers remain active at the end of the program. I am not sure if I edited the ending gcode or not. M84 is the command to disable the steppers, I believe.

If you include the command M84 S0 (thats a zero) at the start of your gcode then the steppers will not time out unless you tell them to turn off. (Assuming there is not a M84 command at the end of your code that releases them.) If there is a M84 at the end, delete it or add “S0” to it to keep the steppers energized. The attached screenshot shows a portion of one of my gcode programs. This sets the steppers to not disable idle hold at the beginning. At the end it raises the Z to 7mm (clearance plane) and then moves X&Y to 0 then just sits there with all the steppers locked. After tool shutdown, I can release the steppers by issuing M84. (Or just release a specific axis by including that after. i.e. M84 Z would just release the Z axis.)

[attachment file=52470]