Z-axis motors skipping

Hi,
I’ve got a persistent issue with my z-stepper motors. They can’t lift the router. If I position the router half way along the Y-axis, no problem. Position the router at either extremity of the Y-axis, and the weight bearing stepper just skips.

Troubleshooting so far:
First, I checked for free movement at both Y-plates with the coupler removed. Free and easy movement.

Second, connected the couplers to the motors, but no power. Free and easy movement.

Third, chacked no physical impediments, snagging etc. None.

Fourth, fitted two new NEMA17 high torque ( 92 in/lbs) steppers. No change.

So now I’m thinking this is either a cabling issue or a firmware issue. The cabling is from Ryan. Connected as per instructions, and all directions etc work as advertised.

Firmware? I seem to recall someone else talking about this issue, and he solved it via firmware fixes, but I cant now find his post.

Any help will gratefully be accepted.

My final avenue is to use Nema23 stepper motors for the Z-axis, but I know this involves all sorts of stuff I don’t know anything about.

Help?

Regards
Duncan

Did you adjust the drivers to accommodate the current for the new steppers?

Unless you have a non-standard, really heavy router, you should’t need Nema23 steppers. Having in run in the middle but not on the edges feels like a mechanical or cabling issue. Check the grub screws on the coupler. Run out on the Y until you have a problem, release the steppers (M18), then turn the lead screw by hand and see if it is binding. You can compare the turn difficulty to how if feels when the router is in the middle. Release the end of wire chain where your Z axis runs and manipulate the chain by hand while running the Z axis up and down in the middle.

Hi Tim,
No I didn’t. I have no idea how to do so. Pointers? Web reference?

Thanks
Duncan

Ahh, OK. This might be your problem all along. What kind of controller board are you using? Also, what stepper drivers are you using? Board= SKR, RAMPS, etc. Drivers= A4988, DRV8825, TMC22xx, etc.

Edit: Pictures would be best!

Also, could you post a link to the new stepper motors you bought?

Hi Robert,
Just a regular Makita. Grub screws checked. Tight as possible. Ill try your checks.

Duncan

Drivers? No idea. Rambo 1.4 from Ryan.

Steppers:


Board:

Regards
Duncan

Sorry man, Rambo board has stepper current configuration in the firmware. Not familiar with that. I’ve only dealt with stepper drivers with manual adjustments. My guess is that’s where your problem may lie. Both steppers can lift the gantry, but when most of the weight is shouldered by just one of them, there isn’t enough current, so it skips.

Hi. Thanks. Surely I can’t be the only one with this issue? The gantry is at the extremes a lot of the time. Let me take a look at the configuration files and see if anything stands out.

Cheers,
Duncan

Hi again,
As a complete novice when it comes to electronics, boards, configs etc, it would make life a LOT easier if someone could give me a step-by=step on how to check/ verify the current to the stepper motors. I understand each individual word, but together in a sentence they make no sense to me at all.

Regards,
Duncan

OK, poking around on Google I found this:
Below is where you can find the firmware settings on printers with digipots.

Marlin: Configuration_adv.h setting called DIGIPOT_MOTOR_CURRENT

Boards with digital current control:

  • Rambo

Great - my current config_adv_h mfile reads:
#define DIGIPOT_MOTOR_CURRENT { 138,138,138,138,138 } // Values 0-255 (RAMBO 135 = ~0.75A, 185 = ~1A)

I have no idea what this means, or if it should be changed.

Then I came across this: (https://marlinfw.org/docs/gcode/M907.html)

M907 - Set Motor Current

control Set motor current via digital trimpot DIGIPOTSS_PIN|HAS_MOTOR_CURRENT_PWM|DIGIPOT_I2C|DAC_STEPPER_CURRENT

Description

Set digital trimpot motor current using axis codes X , Y , Z , E , plus B and S . The unit used for current depends on the type of stepper driver.

Usage

M907 [B<current>] [C<current>] [D<current>] [E<current>] [S<current>] [X<current>] [Y<current>] [Z<current>]

Do I need to do any of this in order to beef up my Z steppers? Or none of it? Completely confused.

Duncan

SOLVED!
I re-flashed the firmware, with the following settings:
#define DIGIPOT_MOTOR_CURRENT { 138,138,220,138,138 }

Now even firm downward pressure on the router in its extreme Y-travel position doesn’t fase it. Easily lifts without skipping. All I have to do now is to monitor stepper motor temp, and reduce the current if necessary.

Regards,
Duncan

2 Likes

Yeah. That number is going to make a lot of heat. The steopers and the drivers can overheat. Too much heat on the motors can make the plastic soft, and the motor mounts will sag. Too much heat on the drivers and they will just shut off, for a few minutes, to cool down.

The rule of thumb Ryan uses is 50C on the motors. If you stay below that, you will be ok. I don’t know how far above that you can go before you have trouble. 220 from 138 is a huge change. Smaller changes like 140, 145, etc. Would be where I would start. Make sure to save those changes with M500 or you will lose those on a reboot. The heat is nearly the same when they are moving and stationary. A lot of people don’t know that.

There should be plenty of power at the standard settings. Like you said, you can’t be the only one to have this problem. I just don’t know what the issue could be. The leadscrews can bind up if you don’t lube them, or the nuts are too tight and they bind up.

It’s really hard to use your hands as a test. People have wildly different opinions on how strong the motors need to be. They have to lift the router and gantry while milling. They don’t have to overpower a grown man. I trust you are doing your best to get a feel for the strength, and I trust you are having a real issue. I am just cautioning that blasting them with current to meet high expectations might be hurting more than helping. YMMV.

1 Like

Hi Jeff, and thanks for the feedback.
I reduced my Z current to 150, and the bloody Z-steppers start clacking at the slightest provocation. So I’ve boosted it to 180. (I got the original 220 setting from some guy’s post on one of the CNC forums, so figured it was a place to start…) Tested 180 with added weights. It will now lift the router and 1kg of nuts and bolts in a plastic container. So I’ll continue to play with this. But heat is my enemy now. Might have to fit cooling fins…
Duncan

2 Likes