Z Axis moving only in 1 direction

-Vicious 1 board
-Machine has worked multiple times without a flaw
-No End stops connected

I have been using the Repeteir Host and the z axis for some reason keeps only going one direction(up) no matter what Z Direction I want it to go.

I have disconnected and reconnected but it is not solved by resetting but instead it is sporadic and only when I disconnect the actual power cord to the stepper and I reconnect it will it work (not every time though).

I think it might be a stepper driver but I don’t know why it works sometimes and not others… any help would be great

As you can see it works …just can’t figure out why it will change mid run or even when I am just manually controlling it

Swap a driver with a different axis and see if the problem follows or not.

Make sure to do that with all the power off and disconnected.

Thank you! That definitely works but it kept happening after for a while. I then mixed them all up and it seems to be fine…definitely got some good cuts today, this thing is tits


Have you ever tried doing a Wood relief carving?


So I tried to run two different programs twice today and for some reason in between the different intra-program runs (Engraving vs Carving)… the Z - stepper motor would go from working perfectly to then only running in one direction again, UP… I switched all the stepper drivers and same thing happened…worked for a little and then randomly stopped working and went only one direction, UP…I don’t get why it keeps shorting the Z axis only, it works amazing otherwise…thoughts on what it would be?

That sounds like it thinks an endstop has been triggered on the z axis. Any stray wires or anything touching the endstop pins?

I found out it was actually my drivers overheating because i didn’t have a fan on them…after that, I’ve had random occurrences of the z axis stopping but once every 20 hours+ of running…this thing runs all the time now…2nd one on being built next week…,what is the best laser module to use and power source?