Z-axis shift?



A couple of months ago I built my CNC but didn’t end up using it much until now when I started a project that required it. I did some small stuff in wood to get used to the machine and everything worked out great. I then moved onto cutting in styrene and that went well too.


Now I have been using the machine a couple of weeks and I´ve noticed I´m getting some z-axis shift and I cant figure out what changed.

I thing it came gradually so my first idea was that the belts needed tightening. That did not help. I did however have one cable tie snap and I replaced it with another one. Can this be my problem? I replaced it with a regular cable tie.

I have also checked all my grub screws and everything. When the power is on the gantry seems very stable. I have tried chancing end mill, speed and depths of cut.


I did run into one issue, I don´t know if its related to my problem. When I built the machine a cable to one of my end stops seemed flaky and sure enough after just a couple of uses the cable stopped working. I haven´t been able to find a replacement locally yet so I have been homing my y-axis from the controller and then pushing my x-axis manually to the end stops. Things cut straight and circles are round so I don´t know if this can do anything?

For software I´m using Estlcam.


Here is a picture of a wood part showing straight edges:

Another picture of styrene showing straight edges:


And there is my current problems showing the steps:


Thanks for any suggestions!


That is an X or Y shift, so either a loose pulley or your feedrates and/or rapids are incorrect causing an ignored step.

Thanks for your support.

The pulleys are not loose, I have checked them several times. The rapids are set to 2100 as to the setup guide.

Could this be caused my to lose or to tight belts? That´s the only thing I can think of that can has changed over time. I noticed right now that some of my belts seem very tight… I might have over tighten them…

If you over tighten, yes, it can skip steps. I have a rating in the instructions it is something like a few lbs force (less than you think).

Ok, so I removed all the cable ties and put in new. Tightened them just enough for the belts not to slip when moved by hand. Way loser than before. Still have a weird step. I should say that this step seem to go all the way around, its like it cuts a bigger part when it moves down. Its 3mm styrene and I have 1mm depths of cut, so its 3 passes.


How about a picture of your machine and how you use it.

Its very messy right now… need to vacuum, but here it is!


So… How do I use it? I put the .dxf file into Estlcam, make the cuts, put the gcode on my sd card. I manually move the bit to the top of the styrene and power up the machine, then like I said my x-endstop is broken so I home the y-axis and then manually home the x. Then I run the code…

That cut does not look very good at all, and a step all the way around can not happen from the machine alone unless the spindle is bad or you have a bent endmill. At this point I would assume your Gcode is bad.

What endmill and estlcam settings are you using,

Hm, I have changed the endmill and I have cut probably 20 parts with different gcodes the last week trying different things… maybe my spindle is bad? :confused: