Z axis Shuddering and inaccurate

I am having a problem with my Z-axis that you can see here:

This happens only when a program is running and not when manual jogging. It also happens when the stepper is completely removed from the Z assembly. It only happens when the assembly is being raised not lowered.

Any ideas?

If you bought it from me it could be a few things. Your anti-backlash spring could be too tight, or just take it all together, most people are over doing this. Your plunge rate could be too high, or your rapids.

If you did not get it from me there could be a few more issues.

If you are sure those are not your issues you can try the new firmware. here

Hey Ted,

all the electronics were bought from you, ive yet to test with a meter to see if the voltage is correct but i will do that and then ill try the new firmware. Its not the anto back lash as i have the motor completely disconnected from the assembly and it is doing that shuddering. Thanks!

I think this is my problem as well. It goes down smooth but on the way up it always finishes the movement with the stuttering action that is shown in the video. So the tool ends up lower than it should be. Any solution to this? I am wondering if slowing the z axis would help? Not that I would know how to do that.

Try the beta firmware.

I have the same issue. Manual control works perfect, but executing a program generates this stuttering as if the stepper doesn’t know wich way to turn. And indeed, only in the upward direction, so the tool (or in my case a pen) is driven into the paper. I’m not using the anti-backlash spring.

I have experimented with the current. Initially calculated the value as shown in the video and the explanation. But I have to crank the current up way to much from the 300 mV, up to 1 V, and introduce new problems that way (skipping), and a overheating driver.

I am using the beta software, which is great for x and y. Have done the testscripts. Still a bit puzzled on how to setup the speed slider in Repetier. If I slide this up, I get the same issues on the X and Y axis, which would indicate a “wrong” z-axis value somewhere for our configurations.

I’ll let you know if I find anything.

Hmmmm, lets take this one step at a time. Your on the beta firmware so that is good. it very well could be you plunge rate, what are you using? Start low at about 2mm/s and keeping going up until the problem happens. This is probably the issue.

The last time this happened in the forum the corner of his dewalt was hitting the bearings, so check you clearances.

I hate when people are having issue and I can’t come to your shops and help out. I know these forums aren’t the easiest way but hopefully we get you guys running soon.

The repetier slider is a percentage of whatever is specified. So if your cut is 10mm/s and you set the slider to 150% you should be moving 15mm/s.
The test script is running each axis at its maximum speed, it should not work above that that explains the slider problem you had. maximums for my hardware as sold and beta firmware is 197mm/s X & Y, 8.7mm/s Z those are max. you can double that by going to 16th stepping but that’s fast enough for me.
The Z axis useful speed depends on what tool you have on it , and what material you are cutting. Once you find your values everything should work fine. The beta firmware slowed down the accelerations to allow for max speeds and high plunge rates by I doubt you could plunge and lift at max speed with a router on the Z axis.

I have youre values, and calculated the rest:

#define DEFAULT_AXIS_STEPS_PER_UNIT {200,200,5120,200} // default steps per unit for Ultimaker
#define DEFAULT_MAX_FEEDRATE {195, 195, 8.7, 25} // (mm/sec)
#define DEFAULT_MAX_ACCELERATION {400,400,55,800} // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

#define DEFAULT_ACCELERATION 400 // X, Y, Z and E max acceleration in mm/s^2 for printing moves
#define DEFAULT_RETRACT_ACCELERATION 800 // X, Y, Z and E max acceleration in mm/s^2 for retracts

If I understand you correctly, setting the slider at 100% will result in 195 mm/sec for the x and y, and 8.7 for the z-axis. I will experiment some more to find the “sweet spot” for my steppers. Thank you for replying so quick!

No, setting the slider at 100% will move at 100% of what you tell it to do. So for the scripts I put up yes 197, but for cut and print moves more like 20-30. Best is not to touch the slider ever. leave it at 100, make all your speed changes in the gcode.

I understand. The strange thing is that the torture test for the Z-axis works without a problem. Just actually printing something generates the stuttering.
Where can I find the plunge rate? Searched the source code, but couldn’ t find it.

Plunge rate in estlcam, or your slicer as z axis movement rate or something similar.

I think I have solved the problem. Changing the plungerate to 2mm and to 1 mm did not solve the problem. So I tried to increase the current to the stepper by 50 mV at a time. Went from the calculated 340mV up to 840mV, and the problem was solved. The stepper and the driver get hand-warm, even after intensive testing the z-axis, so I am good to go. During testing I also discovered a flaw in the y-axis stepper current. I printed a drawing of the world a couple of times on the same sheet, and Australia almost collided with Africa after five prints. I Increased the current to those steppers also 50mv, solved the problem and saved two continents at the same time :wink:

Nice! You’re a hero, You saved half the world and got a cool tool out of the deal, that’s a good day right there!

So many variables on this thing I’m glad you figured it out.

I solved my problem by making a change in the Marlin file. I am currently using Marlin_16_32_090615_therm

I made all the adjustments as lited on your page, https://www.v1engineering.com/marlin-firmware/ but i had to tweek one line. Changed my z feedrate from 8.7 to 4.

Original #define DEFAULT_MAX_FEEDRATE {195, 195, 8.7, 25}
adjusted #define DEFAULT_MAX_FEEDRATE {195, 195, 4, 25} // (mm/sec)

If anyone is having problems with hearing a stuttering sound when lifting the Z axis this might be the fix for you. Same issue if each line of your print job is lower than the first.

The beta would probably have worked too (with the same adjustment as above) , might test that in a few days but for now I am really happy with the results I am getting so I am not rushing into more changes.

You are using the old firmware, use the beta. It is not an issue of max speed it was acceleration that was fixed in the beta firmware. as well as a few other small things. Worth changing you need the z axis speed trust me.