z axis slipping

wondering if anyone else has had this issue. When setting my z axis to the material surface before cutting, it doesn’t stay in place it falls down and drives the bit into the material therefore throwing off my z axis start point and making it lower. any thoughts?

The lead screw and nut rotates so smoothly that the weight of the spindle lowers the x-axis.

You can increase the pressure of the bearings against the tubes a little by tightening the correct nuts.

Or power on the steppers by moving them with the screen a mm and then back, they will then hold for 6 minutes. Having that smooth of a Z axis is a very good thing.

1 Like

I’m having the same problem. The vibration of the 660 will drop the tool immediatley after the print job is complete, I have zero time to turn it off before it plunges into workpiece. I have tried adding the M17 (enable steppers) into the Repetier Host ending gcode script to try to help keep it up, but it doesn’t seem to work. For some reason, all steppers are disabled at the end of a job.

By the way, anytime I give the M17 command through Repetier Host, the Rambo 1.4 will beep/click and the connected LCD screen flashes between info screen and menu screen. I have to rush to the power cord and un plug.

Update your firmware, the steppers should stay energized for 6 minutes after your cut unless you are issuing a command to turn them off in your gcode.

Okay thanks, I may try that too.


I was not, just what factory install was doing.

This is what I just found that works for me now, and anyone else that may have this same issue. If using Repetier Host, you can use the @pause gcode command to hold the tool in place with steppers on while you turn it off. So in ESTLCAM, I added this:

Program Start:

G1 Z5 ; engage z stepper
@pause Turn on router now

then at Program End:

@pause Turn off router now

This is also a good way to not forget to turn on the router before carving. However, my steppers are still de-energized after completion, and any little bump the z axis will slowly slide down. At least now I have time to turn off the router. I guess I shouldn’t have used that good lube on the lead screw.

thanks a lot for the info :smiley: