Z-axis Still giving me a problem after everything

Machine has a footprint of roughly 23x24" cutting area roughly 15"x13" and is square in every dimension etc…

I hate asking for help, and I have tried to research this thing to death, but I am about out of tricks in the bag to figure out why my machine plunges too deep. I know this is an issue that has been brought up many times on the forums, and I have tried to go down every rabbit hole that I could find to get answers. I would be extremely appreciative if anyone could give me some advice.

The issue:
Inconsistently the machine will cut too deep. I can print the same G-code 4 times and 1 or 2 might be perfect, and the others randomly cut too deep or plunge straight into my table with me lunging for the emergency stop.

What things I have tried to do to fix it:
First I tried to look at it as a mechanical issue. I took the z axis back apart, and discovered my pineapple coupling was loose. I tightened it up and reassembled and it seems to be firmly in place still after that adjustment. I haven’t seen any other mechanical issues seem to come up since then.

I did a lot of reading to try to solve this, because I was still having the problem.

Read through: https://www.v1engineering.com/forum/topic/z-axis-plunging-into-material-randomly/

and a few others. I ended up slowing feed rates, that didn’t help.
Changed to Fusion 360 which was a bit of an effort but now I am starting to get comfortable with that.
Changed feed rates in Fusion, and double checked post settings.
re-flashed my Marlin firmware based on the software link to Marlin on this site.

I am still having this problem though.
My feed rates in Fusion are currently 900 mm/min
I have Rapid Retract turned off
I also switched it to always use High Feed (to cut out any fast moves)

So, the only solution I know of that I haven’t tried is that I have seen a few people talking about upping power to the steppers, but I haven’t seen where that option is. Would this be my best next avenue, or has anyone else found a solution I haven’t tried?

Thank you in advance for any help!

Attached picture shows result of bit diving too deep into material on the same file at different times.

What version of the software are you using? Both have been updated, https://www.v1engineering.com/software-updates/

900mm/min is 2x’s too fast for the z axis.

If you don’t think that is it, please answer all the questions in the sticky, also zip up your gcode and let’s see it.

I think this may be an issue with your Z axis stepper driver running overpowered or underpowered.

Try adjusting the driver, here is a great tutorial video to explain how and why:

Thank you both for trying to help me out!

Sorry that I missed that Sticky.

  1. Did you buy everything from here? Yes bought all parts/electronics etc from your shop.
    a)If you didn’t or changed some things please don’t leave out any details and include what firmware you flashed. Flashed new firmware RC7 yesterday.
  2. Are you using end stops? No
    a)If so please disconnect them.
  3. Mac or PC? PC
  4. Include a picture so obvious errors might be spotted. Picture attached but it is only of the machine not myself so it may not actually include the obvious error haha

My Z-axis plunge in Fusion is set to 200mm/min -forgot to mention that in the original post. Also, forgot to mention my Z is setup for 4 inches of cut height area if that becomes relevant at any point. As for versions of software/firmware Fusion360 and Estlcam are the most current versions offered from their corresponding sites. Marlin version is RC7 from this site. Repetier host version is 1.1.2 (most recent pretty sure), and for the post processor in fusion I am currently running the one from workerdrone I found on this page: https://www.v1engineering.com/forum/topic/fusion-360/

I am going to try to switch the post to the one you linked in the software update to see if that helps my issue. I had 4 successful cuts in a row last night after closing and restarting Repetier host each time, but trying the same thing this morning got me another nose dive into the waste board.

I started looking into this power situation with the driver, thank you for that link Dui, ni shuo de dui!


;RCMedal endmillcuts slower final
;T1 D=3.175 CR=0 - ZMIN=-6.4 - flat end mill
N10 G90
N15 ;Units in mm
N20 G92 X0 Y0 Z0

;2D Adaptive4
N25 G1 Z15 F2000 ;T1
N30 M106
N35 G1 X40.324 Y43.762 F2000
N40 G1 Z15 F2000
N45 G1 Z5 F900
N50 G1 Z2.868 F900
N55 G1 Z2.55 F900
N60 G1 X40.438 Y43.867 Z2.545 F900
N65 G1 X40.563 Y43.96 Z2.539 F900
N70 G1 X40.696 Y44.04 Z2.534 F900
N75 G1 X40.837 Y44.105 Z2.528 F900
N80 G1 X40.983 Y44.156 Z2.523 F900
N85 G1 X41.135 Y44.191 Z2.517 F900
N90 G1 X41.289 Y44.211 Z2.512 F900

This feedrate will cause problems to your Z axis I think:

N25 G1 Z15 F2000 ;T1

Yeah and there are a few other big moves at 900 2x’s too fast. If you are using fusion you you need a new post processor. V9orv10

Ok, I have updated my post processor, and I noticed that my End mill bit plunge feed rate was wrong from copying a different tool in Fusion also.

Here is the updated version of the previous G-code if you guys don’t mind checking my work again! Thank you for the help, I feel much closer to this working right now.

;RCMedal endmillcuts V9post
;T1 D=3.175 CR=0 - ZMIN=-6.4 - flat end mill
;Units in mm
G92 X0 Y0 Z0
M84 S1800 ;Change Stepper disable timeout to 30 minutes

;2D Adaptive4
G1 Z15 F400
G1 X40.324 Y43.762 F2000
G1 Z5 F900
G1 Z2.868 F900
G1 Z2.55 F900
G1 X40.438 Y43.867 Z2.545 F900
G1 X40.563 Y43.96 Z2.539 F900
G1 X40.696 Y44.04 Z2.534 F900
G1 X40.837 Y44.105 Z2.528 F900
G1 X40.983 Y44.156 Z2.523 F900
G1 X41.135 Y44.191 Z2.517 F900
G1 X41.289 Y44.211 Z2.512 F900
G1 X41.444 Y44.215 Z2.507 F900
G1 X41.599 Y44.202 Z2.501 F900
G1 X41.751 Y44.174 Z2.496 F900
G1 X41.9 Y44.13 Z2.49 F900
G1 X42.044 Y44.071 Z2.485 F900
G1 X42.181 Y43.998 Z2.479 F900
G1 X42.309 Y43.911 Z2.474 F900
G1 X42.428 Y43.811 Z2.469 F900
G1 X42.537 Y43.7 Z2.463 F900
G1 X42.633 Y43.578 Z2.458 F900
G1 X42.716 Y43.447 Z2.452 F900
G1 X42.785 Y43.308 Z2.447 F900
G1 X42.839 Y43.162 Z2.442 F900
G1 X42.878 Y43.012 Z2.436 F900

I figured I’d test this because I’ve been having issues with my Z. Cut looks good and the speed was ok. The only thing that caught me off guard was the plunge depth. I usually do a few passes at 1mm, this dove right into ~6mm.


Yeah, I ran this again and even with the new post processor and speed it cut right into the waste board again. It isn’t a consistent problem either though. I got about 5 cuts that worked as expected out of this same set of tool paths. That is why I was starting to wonder if this is a power issue with the stepper. I would have thought if this was a feed speed issue that it would be consistently failing essentially every time.

Also about it going deep on the first pass, it is an adaptive clearing pocket tool path from Fusion 360. I don’t know much, but based on what I have read End mills actually do better if you get them into the material, because they cut primarily from the side so this path is supposed to helix down into the work piece then start clearing away. Looks like it came out well on yours. I have 4 or 5 now from this toolpath set that came out looking right, and a lot more that did not.


Are you getting any errors in Repetier when the print is running? I’m far from knowing what the issue your having is, but last week I was printing a pirate ship relief onto foam, and a short way in, it went crazy and deep into the spoiler board. I chalked it up to beginner mistake, but it seemed like it couldn’t keep up with the code. Wondering if it’s a comm issue.


Some of your z moves have a feed rate of 900. Listen/watch the stepper during one of these commands. It will probably buzz and not move instead of raising the z axis up. The next z move will drive it down further then it should be because it missed all of those steps. Also check if your pineapple coupler is tight.

Thanks for the support/advice guys!

Zeenon, I didn’t get any errors in Repetier host all I get is the plunge into the board. Hopefully I’m eliminating enough factors that I will escape this soon.

Joe, I am trying to figure out what the deal with these feed rates is. I am generating these tool paths from Fusion360. I have only been playing with that since last Monday so I am no expert on it for sure, but I thought I had figured out how to set feed on it.

At the bottom of the page on this link it has some feed maximums:

The rates are listed as " Max XY speed is 190mm/s and Z speed is 8.5mm/s, MAX. This is your max speed for rapids"

In fusion’s Cam tab under tool i have a cutting feed rate of 900.001 mm/min (which should be equal to 15.00 mm/s) and a plunge rate of 254 mm/min (which should equal 4.24 mm/sec)

For some reason though it doesn’t seem like fusion or the post processor is taking it from mm/min to mm/sec properly.

I did up my voltage on the current limiting pot today to .74 from .67 and continuously ran the G-code “G1 Z15 F900” and once out of about 10 times it did hang up so I do think that speed is possibly my issue. I just need to figure out why it is getting that speed setting. I am going to try changing settings in fusion360 and sending them to post till I get that changed before any more cuts.

Thank you all for the help.

So, I played around with my inputs from Fusion360, but I don’t believe that is where my rapid movements that are causing problems seem to be coming from. It looks like the V9 post processor is the only place that they could be coming from?

one of the lines from my above g code:
G1 Z15 F2000

Absolutely none of my fusion settings include a feed speed of 2000. So I couldn’t figure out where this would be coming from, till I looked through the post processor.

The high feed rates appear several times in the post’s code:

// user-defined properties
properties = {
writeMachine: true, // write machine
writeTools: true, // writes the tools
preloadTool: true, // preloads next tool on tool change if any
showSequenceNumbers: false, // show sequence numbers
sequenceNumberStart: 10, // first sequence number
sequenceNumberIncrement: 5, // increment for sequence numbers
optionalStop: true, // optional stop
separateWordsWithSpace: true, // specifies that the words should be separated with a white space
useG0: false, // allow G0 when moving along more than one axis
highXYFeedrate: 2000, // Set XY rapid feedrate - only active if useG0 is false
highZFeedrate: 400, // Set Z rapid feedrate - only active if useG0 is false
enableM106SpindleControl: false // Enable M106/M107 for spindle speed control

Another setting for tool change etc:

if (!isFirstSection() && properties.optionalStop) {
//SLC Edit: tool change retract position
// For
writeBlock(“G1 Z15 F2000 ;T” + toolFormat.format(tool.number));

so it seems to me like these really high feed rates are coming from something in the V9 post processor. I am just going to have to figure out where and why.

Those are the correct speeds we decided on. The units are mm/min. So divide by 60 to get mm/s, approximately 33mm/s and 6mm/s those are low and conservative for the mpcnc while milling/routing.

I think I am confused on something then. I thought you said in this thread earlier that 900 mm/min was 2 times too fast for the Z axis to move? This is sending for it to move at 2000mm/min, I must be looking at something wrong.

Thank you for all the help I am sure it gets old going through all this.

Side note: Manually used find and replace to bump the 2000’s down to 900 and the 900’s down to 450, I am most of the way through my second consecutive cut with no crazy plunge so far.

I don’t know how your code has an initial 2000 z move, double check you have the v9 selected.
I have made tons of cuts on v9 and no z issues in the code. luckily it is one of your first moves easy to always check for. That is the rapid to clearance move I would assume.

I checked and double checked. I am running the V9 post processor straight off the link you sent me too. I have no clue why it is including these 2000’s I can edit it so I’m pretty sure I am clear of this issue now. I’m working on my 4th cut right now at super slow speeds, and if I get a consistent result from it then I am going to try bumping my normal cut speeds back up to their previous conservative and functional speed, but still knock those 2000’s out of there and see if that gets me to a more stable/practical solution.

It has actually been a good learning experience, although at the expense of some boards I suppose. I have a much deeper understanding of how all of the pieces of the puzzle fit together now, which I am actually very thankful for. That’s what it is all about anyway.

I posted a picture of three of these cut outs that turned out successful. I am using them to make a mold for some Aluminum cast versions that will be used for a race my wife is putting on so we’re both excited that we are getting these things figured out.

I just swapped out computers and don’t have fusion on here yet. There is something fishy about that beginning gcode. do you have it set to do a tool change or something?

N25 G1 Z15 F2000 ;T1
N30 M106
N35 G1 X40.324 Y43.762 F2000
N40 G1 Z15 F2000
N45 G1 Z5 F900
N50 G1 Z2.868 F900
N55 G1 Z2.55 F900
N60 G1 X40.438 Y43.867 Z2.545 F900

n25 Move up really fast
n30 Fan on
n35 move to startposition
n40 move up again? to the same position?
n45 move down Rapid
n50 move down again, rapid??
n55 move down again, rapid???
n60 maybe the actual program starting point.

Can you put up a screenshot of your cam tree. Generally it starts at zero, moves up to the clearance plane, over to the starting point, ramps down slowly into the cut.

Original speeds for that tool-path set etc attached from fusion

Good News:
I have narrowed it down to those 2000 moves that were causing the issue. I have not had the issue since I changed that, so now I am hopefully back on track with that.

Bad News:
One/all of those plunges apparently cracked one of my 3d printed brackets. It is the top corner piece on the back left of my machine. I checked and at least so far it is still square and not having an issue from it, but I don’t really trust it to survive too long.

I am trying to decide what to do about it. I have a M3d printer So I might try to print a new one first, but my printer is small and slow so I am not sure if it will be able to do it or not. I am kind of teetering between that and just going ahead and buying the mk8 extruder/mount/driver on here so that I can go ahead and start printing some replacement parts for issues like this before i do any more damage.

OK, so got my new Top corner piece printed and in place. It seemed to go smoothly. One 3 hour print, one new zip-tie and a few minutes to swap them and I’m back in business and still square in every dimension.