Z axis travels a fourth only

Hi guys,

 

This is my first post, I hope to have a good time here :slight_smile:

Unfortunately I do have some troubles with my MPCNC. I tried to mill the first time and recognised that my z axis travels only a fourth the way I tell the machine. When I travel 1mm with the LCD-controll or by repetier-host, the machine only does 0,25mm. 10mm in software -> 2,5mm in real, and so on. The first time I measured it with my caliper, then I measured it with a dial gauge to make sure the real travel is exactly a fourth of the software travel.

The X and Y axes do not have this problem.

I use the miniRAMBo with Marlin 1.1.0-1 from the shop.
These are the steppers I use: https://www.ebay.at/itm/5PCS-Schrittmotor-Nema-17-Stepper-Motor-59Ncm-2A-4-wire-1m-Cable-3D-Printer-CNC-/192468919128?hash=item2cd00aa358
and the T8 leadscrew: https://aliexpress.com/item/T8-Lead-Screw-Rod-OD-8mm-Pitch-2mm-Lead-2mm-Length-150mm-500mm-Threaded-Rods-with/32760102869.html?spm=a2g0s.9042311.0.0.27424c4dVW1a5J

I do not use endstops.

I use ESTLCAM and repetier-host for Windows 10.

Please tell me if should make a picture of the middle assembly :slight_smile:

Thank you in advance!

Yours, Markus

That is a little different than the one the board is flashed for, just increase your z steps by 4x.

1 Like

Thank you Ryan!

You mean the T8 leadscrew different from yours?

Yes, yours appears to be a single start, I sell 4 start screws. No big deal just change your steps and everything will be fine.

2 Likes