Z drops lower than it should

I only noticed this on the weekend. I started carving a design on some MDF and about 30% through the job, (after it lifted to move to another part) it plunged (at a guess) about half a mm deeper and continued on its way. I then let it finish and tried it again on another piece, and this time it went about 70% before it plunged deeper than it was told. Both times it happened after Z lifted and lowered onto another part of the piece. The display was showing the correct Z amount the whole time, even after it unexpectedly plunged lower than it should have. Both times seems to have dropped by the same amount.

Could the Z motor be losing steps? What should I look for?

If I was to convert to a lead screw with a coupler, what size/type of lead screw would I get?


Thanks John

Sounds like you have not set the Z axis rapid feedrate, or you have a binding axis.


Hi Ryan,

I have set the correct rapid feedrate, so I guess it may be a binding axis? Everything seems to be moving freely so I don’t know how.

Some pictures and what z plunge rates are you using?

Can you move the z axis it’s full length of motion with your fingertips?

There are tons and tons of threads about this and it is usually the z speeds, every once and a while it is some sort of binding.

Using my firmware? what board? what drivers, what steppers, what are your drivers set at?


My plunge rate for Z at the time was 1mm/s. I just went outside now to test the Z movement up and down, and I must admit it came to a point where it was abit hard to turn the coupler as I was going down. I repeated this about 10 times and it’s now all moving smooth. It was only the first time that was a bit hard. I put some lithium grease spray on the bearings as well.

I’m using your firmware with ramps+arduino with DIV268N drivers. I’m running the drivers at 1.2A, 1/16 steps. I put quite a bit of pressure (quite a lot actually) trying to hold Z while moving to see how much torque it has and I was unable to stop it from moving so it doesn’t look like it’s skipping steps due to not enough torque.

Either way I might just order a lead screw and a coupler. They’re only a few bucks from the slow boat in China.

I will give it another go tomorrow and see how it goes.

So here are pics of what I was trying to do.

The circle on the right is the first attempt and i let it finish (I think). Notice the leaves that are much wider, this is where it plunged deeper. The circle on the left is the second attempt. It went alot further before it also plunged deeper and made thise wider cuts. I stopped the second one from finishing no point.

The shot that shows the circles being…not circular and on top of each other leads me to believe your machine is pushing down really hard, and those cuts all have a fuzzy edge. Are you using a proper bit?

I’m using a router V bit that came with my handheld router. I have ordered some 10 and 30 degree V carving bits but still waiting for them to arrive.

In regards to the machine pushing down really hard, I had that job set to 0.5mm per cut at a total 1mm depth, so 2 passes at 0.5mm each.

I’m going to go through the machine today and see what else I can find, but I’ll try again and see what happens.

Some router bits don’t have a tip on them as they are meant to chamfer an edge. 0.5mm DOC is nothing I suspect a poor bit is the issue here.

So you think a poor bit would contribute to the sudden change in Z height during a job?


I just went out and tried the exact same design again with a different but still a router V bit and the opposite happened. About 3/4 of the way through the job it actually lifted, so from that time on, the first pass was cutting through air, then on the second pass it cut the remaining 0.5mm

Well there is something fishy going on here, that is a first for sure.

Try my test gcode again, a few times. Lets figure out if it is a hardware or software issue.

Test Gcode? You mean the crown? If so, do you want me to carve it using the same V carve bits?


Also, I’m wondering… if the thread has warn around that area where it spins on the nut. I will pull it apart and have a look.

It keeps doing it as I just tried some aluminium with a brand new 3.18 single flute bit. It was doing a hole, and as it finished the hole, it lifted, made a bit of a noise then went down again ( I accidently told ESTLCAM to cut that hole twice) and started cutting it at around 1.5mm deep instead of 0.2mm that I had it set per pass, so I stopped it. It did cut the hole really nice mind you

It doesn’t look like much but you can see about 3 turns have damage. My guess is, that is the culprit. What do you think?

SSo do I just flip it over and try again or should I just order a leadscrew and be done with it.

Some suggestions:

Try it with foam. That will confirm it’s the machine having trouble moving, or some combination with the work.

Put the material on something to lift it up an inch, to avoid those bad threads.

Check your z wiring. If one wire is loose, it might be skipping a step, but only when you’re pulling on it right and moving the z.

I’ll check the wiring today. I’ve ordered a leadscrew but in the meantime I’m going to flip the rod over and see if it does it again.



I checked the wiring and it all seems good. I have all secured through cable chain also, so that part should be all good.

I saw your other post as well, I do think they are related. I think it didn’t pick up and got stuck and dove too deep. Aluminum isn’t a good material to trouble shoot with. Too many variables.

1 Like