Z moves SKR with allthread

I am replaced my Ramps board with an SKR board bought and Flashed from V1 last month. I am using the original Allthread provided with my original MPCNC purchase. My Z axis is not moving the correct distance. What could be wrong and how do i fix it.
Thanks for your help

Allthread usually refers to threaded rod. Are you upgrading your electronics on an old MPCNC that uses threaded rod, or do you have a more recent build that uses a lead screw? The firmware that V1 ships on that board is set up for T8-8 lead screws. From the display as well as from g-code you can set the steps per millimeter, but before you do that, you should understand why the problem is occurring. It is likely one of:

  • Older machine with a thread rod instead of a lead screw, so the steps need to be adjusted.
  • Mechanical problem that is losing steps. Usually some sort of binding, friction, or loose grub screws on the connector between the stepper and the lead screw.
  • CAM problem that is attempting to move Z too fast resulting in lost steps.

There are a few other rare reasons.

I don’t know if you can access steps/mm from the TTF, but if you hold down the knob for a few seconds, you can put your display in Marlin mode. From that menu select Configuration/Advanced Settings/Steps per mm.

The skr pro firmware uses 1/16th microstepping. I remember the allthread and 1/32nd being 4535 steps per mm. So half that would be 2267 steps per mm.

M92 Z2267

If that works, then M500 to save it.

It has been a long time since we had a question about allthread. How is your cnc doing?

1 Like

It’s doing ok. It’s been in storage for a while due to relocating. It’s not missing steps and it’s not slipping at the “pineapple”. I get the M92 code into the firmware by entering it into the repeater by using the 'manual G code entry line?

Yeah. I forget the name, but that sounds right. There is a send gcode button.