Z Probe Touch Plate

I’m having trouble getting the Z probe/touch plate gcode to work on my LowRider 2 (with dual endstops and SKR/TFT). Everything looks fine (triggered) when I send an M119 command. I can’t figure out how to get the LR to probe down though. I’ve tried both G28 and G38.2 but neither of them work for me. I’ve also copied the exact example code from the dual endstops page and the milling basics page and neither work for me.

Below is my gcode (2 inch x 2 inch square). When I press the cut button it pauses, Z goes up, pauses again, then it proceeds to follow the rest of the code.

Thank you.

;Project Tool Change Test V1 Code
;Created by Estlcam version 11 build 11.222
;Machining time about 00:00:42 hours

M0 Attach probe ; Remind the user to attach the probe
G38.2 Z0 ; Home down for the touchplate
G92 Z19.05 ; Sets the offset for the touchplate, if the touchplate is 0.5mm thick
G1 Z10 F300 ; lifts the Z out of the way
M0 Remove probe ; Remind the user to remove the probe
G00 Z5.0000

;No. 1: Engraving 4
G00 X50.8000 Y50.8000
G00 Z0.5000
G01 Z0.0000 F240 S24000
G01 Z-2.0000
G01 X0.0000 F480
G01 Y0.0000
G01 X50.8000
G01 Y50.8000
G00 Z5.0000
G00 X0.0000 Y0.0000

M05

It’s the feed rate:)
Have a look here:

Did you mean to set this to be a 19.5mm thick touchplate?

If so, this is going to crash the tool 10mm into it.

I personally recommend that you go into Estlcam’s settings (Setup|CNC Programs|Coordinates) and check the “repeat” box for the F value. This will specify the feed rate for all moves, otherwise your program will slow to a crawl every time it lifts the Z.

M0 will not pause the program if you do not have an LCD attached, so that will not work if you want to have the attach/remove probe messages with a pause.

Thank you Olivier and Dan. I won’t be able to fully read the linked post or experiment again until this weekend.

Dan, yes my touchplate is 19.05mm (0.75 inches) thick…it’s this one on Amazon if anyone is curious.
Should Z10 be Z-10 such as G1 Z-10 F300?

My repeat box for the F value is unchecked…will change that. Also, I do have the touch screen and it does pause, but when it pauses it places the message behind the buttons for a second or two (see screenshot ~ sorry about the light glare). Is that normal? It doesn’t show me the message either. It says “Paused for user input” then “Paused by M0.” That is of little concern right now though.

Thanks again.

image

yup! I had the same issue. Since I´ve updated to the latest TFT version that issue is gone.

What I ended up doing, is making a separate Gcode file I called “Basic Operations - Z probe”. It contains the following code:

G21 ; Set units to millimeters, it is safe to assume that it´s already set, but it won´t hurt!
G90 ; Absolute positioning, just in case
G38.2 Z-400.000 F500 ; Probe Z from max Z height, in case it was homed
M400 ; Wait for movement to stop, to be certain
G92 X0.000 Y0.000 Z14.000 ; Set Probe offset to 14mm, thickness of probe, and set X Y axes to 0 from this point on
G00 Z200.000 F2000 ; Raise Z to remove probe
M400 ; Wait for movement to stop, to be certain
M117 X,Y is 0mm, Z is 14mm!

If you´re willing to re-use this script, please know that:

  • G38.2 Z-400.000 F500
    my Z can lift 40cm. most likely yours will be less, but you can leave it as is. Probe will obviously stop at any height when shorted.
  • G92 X0.000 Y0.000 Z14.000
    my touchplate is 14mm thick, you´ll want to adapt to yours
  • G00 Z200.000 F2000
    I raise my Z high enough after probing for easy removing the probe, obviously you can change this if in a hurry
  • M117 X,Y is 0mm, Z is 14mm!
    This is a small screen message that will be shown for 2 seconds, as reminder

This script can be optimized for absolute vs relative coordinates, but that´s still work in progress for me:)
I never use the code in Estlcam anymore, I now run this separate script before each cut. Works just fine!

1 Like

Then you do not want the G1 Z10 command after the home, because it will send the Z from it’s current 19.5mm above the stock to 10mm above the stock, which is 9.5mm INTO your Z touch plate.

… Unless of course you specify a G91 command first, which changes to relative positioning.

I’d recommend changing this block from this:

M0 Attach probe ; Remind the user to attach the probe
G38.2 Z0 ; Home down for the touchplate
G92 Z19.05 ; Sets the offset for the touchplate, if the touchplate is 0.5mm thick
G1 Z10 F300 ; lifts the Z out of the way
M0 Remove probe ; Remind the user to remove the probe
G00 Z5.0000

to this:

M0 Attach probe ; Remind the user to attach the probe
G38.2 Z0 ; Home down for the touchplate
G92 Z19.05 ; Sets the offset for the touchplate, if the touchplate is 0.5mm thick
G1 Z30 F300 ; lifts the Z out of the way
M0 Remove probe ; Remind the user to remove the probe
G00 Z5.0000

for the desired effect. (Just changing the Z value from 10 (9.5mm into the touch plate) to 30 (10.5mm above the touch plate.)