Z probe - wrong direction

Good evening everybody

I’m trying to install a z-probe. As soon as I try to do the z-probe with “G28 Z”, the z-axes goes the wrong way (upwards instead downwards to the plate).

I’ve connected the plate to signal (S) and the spindle to ground (-).
When I do the trigger-test with M119 everything works fine, when touching its triggered, else its open.

So I tried the “G28 Z”-code without the connections to spindle and plate, z-axes moves down as it should but wont stop cause there is no signal. So I tried to connect the spindle (ground) but not the plate (signale). Again, z-axes moves down…

It seems that as soon as I connect the signal to the z-min-signal, z-axes moves upwards. I’ve added my config and config_adv in the annex.

Thanks so far !

eru_configuration_adv_h.txt (188 KB)

eru_configuration_h.txt (159 KB)

Your configuration looks ok, i think the most likely cause is a flipped motor connector. When you jog z+ and z- does it move the correct way? If not, power off the machine and flip the motor connector, which reverses the direction of the motor.

Thanks for taking time. :slight_smile: Unfortunately everything is right. It’s kinda difficult to explain but so far I guess it has something to do with the wiring. The endpoint of the signal is a ring cable lug right now. As long as I do the z-probe with the lug, everything works. But as soon as I try to connect the lug on an aluminium or steel plate, the probe doesn’t work anymore and the z-axes is moving upwards.

I would like to understand the problem to use the plate instead of the tiny lug for the z-probe. Maybe there is too much resistence or some noise? Even if I try to connect the lug to an aluminium foil it wont work. Possible that I have to connect the signal directly to the plate without any connector?


Edit: Possible that the material or how the plate was made, is not suitably as probe-plate ?

What are you using for wire for the plate? Is it shielded, or at least twisted? Try using a wire pair out of a network patch cable, keep them twisted until you get to the plate and tool clip.

So I tried several materials and noone’s working. You think the wire I use is just not “strong” enought ?


I used small cables which fit into Dupont cases.

Not necessarily strong enough, but it could be picking up electrical interference.

It sounds like maybe an intermittent short. Try M119 over and over while you mess with the wires and see if it is sometimes getting falsely triggered. The G28 behavior should always match the M119 reading because they use the same mechanism.

Thanks so far! I’m still not sure how to clear my problem. Is there something like a verbose debug out there in Repetier ?

And may this be my problem, Endstop Noise Filter? http://marlinfw.org/docs/hardware/endstops.html

Something strange happend last days: There is like a “triggered” signal if I come near with my body or my hand (without touching anything) while probing thr X- or Y-axis. As I would trigger the Endstop PCB, without touching it. I guess I really have to install a realtime verbose debug to find out where and when the problem appears.

What board are you using and what firmware? The pin should have a pullup resistor, either external on the board or internal to the chip enabled in software. The pullup resistor prevents it from being in an indeterminate state when not connected to anything. What you describe sounds like it is floating, i.e. the pullup resistor is absent or disabled.

If the board and/or software can’t be fixed, a workaround would be to add your own pullup resistor, say 10k ohms between +5V and the probe pin. When disconnected, it will cause it to reliably read high. When shorted to ground through the touch probe, it will read low.

I’m using an Rambo-Mini 1.3a with the firmware (preconfigurated, MPCNC_MRambo_T8_16T_LCD) 2.x bugfix.

Makes totally sense what you suggest. But for me it seems a too complicated solution, even if it is easy for an expert. I will first try to twist my loose cables together and isolate more with some tape, as example the crocodile clamp. It’s not likely that any resistor should not work anymore. Thanks so far for all the help!

Anyone got an idea for a ‘verbose debug’ to see exactly whats happening while the machine is moving around?

Finally I was able to twist all the wires together, which seemed to help. My endstops for X and Y work perfectly now. G38.2 X-10 or Y-10 are working fine. The machine stops moving as soon it touches the endstops.

So G38.2 Z-100 will move the z-axis down, but sadly it won’t stop when touching the plate, even if M119 says Z_MIN is triggered. I have no clue what to do next.

Edit: G28 Z still won’t work with my metal plate. Just moving upwards instead downwards… But surprisingly it will move down when I connect my wire to a screw…

Edit2: G28 Z is finally working! I enabled #define ENDSTOP_NOISE_THRESHOLD 2. Thanks so far for all the help I’ve got.

On my phone, so it’s hard to search your config files, but I had a similar problem with a printer 3d. The cause was the switch was set to normally open, instead of normally closed. So when it went to probe, the switch reported closed, and the firmware assumed that meant it was already touching the bed, even though it wasn’t. (I might have that all backwards, I forget how that particular switch was designed, but that was basically the issue).


Good luck