Z slip over large topographical map

Very good. I thought this was a step up in precision, which confused me for a bit. Is this a change in the Marlin config file? Will there be a noticeable change in resolution?

Good looking out. The kids and I built it, and we design projects for it, but it is not something we should have on campus as-is. Right now it lives in my laundry room.

Hmmm, changed the Feedrate and Cutrate variables, but it is missing plunge speeds and arcs. Once you get through this project you really need to get to Estlcam or Fusion the PP’s are much more mature. Kinda surprised this works, there were multiple rates on the same line that I had warned them about, they left them in. I just took them out.

Not sure why the Feedrate isn’t repeating but maybe this will work.

You do not have the option to set the feed rate, cut rate, plunge, or rapid?

I’m assuming your using ramps?

http://www.geeetech.com/wiki/index.php/Ramps1.4#Jumper_Instruction

So remove two jumpers. Just under the Z axis. Then change the steps_per_mm for Z to be half what it was. You can change it in the config (it’s an obvious name STEPS_PER_SOMETHING), or using gcode:

http://marlinfw.org/docs/gcode/M092.html

If you screw it up, you’ll be off by a factor of 2, 4, 8 so it will be a quick test to see if it’s working.

There’s been some debate about which microstepping to use. The tile of thumb I use is just to use 1/32 on an MPCNC, unless you have a reason not to. They are practically identical, but the common assumption on the forums is that you’ve got it in 1/32. You won’t actually lose any resolution because the steppers can’t really do a 1/32 step.

1 Like

Attached is clip with new PP.

I’ve also attached Vectric’s PP guide, which might be helpful. I’m not sure what I’m looking for.

I can only set feed and plunge rates. They allow me to set the rapid z height, but I assume they rely on the machine’s max for the actual rate.

Test-2.txt (898 Bytes)

Post_Processor_Guide.pdf (962 KB)

Getting there. Need to add the “f”

I am digging through there guide…It is huge. I found the Z axis at a different rate stuff but I am not sure if I have it correct yet.

Yep, ramps.

I’ll make the switch tomorrow. Seems straightforward.

Ha! Yeah, I was in over my head quickly with that one.

Digging a bit deeper, this software is bundled with nearly 500(!) post-processors of every flavor. I picked one (X-carve) and copied a chunk below. Not a lot there. If you know a machine that might operate in a similar way, I could send that PP to copy from.

xcarve-gcode.txt (869 Bytes)

If this works I can add Arcs as well.

I hope this asks for

feedrate, What we call rapids

Cut rate, What we call feedrate

Plunge Rate, Feedrate for Z axis

I feel like I am still missing something though

 

Marlin_mm-test3.zip (1.08 KB)

If there is a reprap one in there we would be in business I’m sure.

With arcs and more correct Z moves? “test 5”

If that fails test4 corrects my command error from test 3.

Marlin_mm-test5.zip (1.19 KB)

Marlin_mm-test4.zip (1.08 KB)

1 Like

There are genuinely 500 PPs but no RepRap. The community is large enough that I’ll expand my search there tomorrow, probably here.

Doesn’t seem to be a significant change; are the arc moves only used with vector images? I’m building from a raster.

test-5-gcode.txt (919 Bytes)

That looks correct, it should/might work. There should be new plunge commands in there somewhere.

Yup, looks like it. There aren’t many, but my plunge rate is set at 4 mm/s and there are several F240.0s around.

I’ll flash the new firmware tomorrow evening and run Test 5. If things aren’t looking right I’ll switch to 1/16 steps.

Thanks again for your help!

Sweet, once you confirm I can add this to the “trusted” PP list. Thanks for going through all of this and testing. I might still do some tweaking as I don’t like that there is a hard coded speed in there but I am not sure how the speed settings work. Has that cutting parameters window changed to include rapids or is it the same as before?

 

It worked! Used test #5 (above) to slice in Vectric Aspire, RAMPS firmware flashed to Marlin 2.0, config file adjusted for my 5/16" Z axis screw, and:

[attachment file=51429]

Poor lighting, but the cut is perfect—no more drift.

Thanks for all your help! I’ll post the rest of the project as it nears completion.

1 Like

New snag—the x axis stepper socket isn’t responding. I switched the x & y motors (fine) and the x & y stepper drivers (fine), but I only get an idle hum from whatever is plugged into the x axis socket when I send a command. I ran it fine this morning (10 min) to complete a section, set up for a new print, and it no longer moved.

The heat sinks seem very warm, but I don’t handle the board so I can’t compare with normal.

What voltage is it set to? Have you even unplugged a stepper while it was energized?

I don’t know what voltage (bought the kit), but I could measure if I knew which pins to check.

Never unplugged them, never unplugged motors without unplugging mains and USB.

I have never had a board go bad after the fact, only a driver. You are describing a board issue 100%. Is there any sort of debris on the board that could be shorting it, or sitting on anything conductive? You can split the ramps and Arduino to check for anything that looks fishy. This is not a common occurrence, as far as I know the first we have seen here.

Nothing on the boards, and it sits on wood. I checked the sockets as best I could, and flashed back to the previous firmware just to make sure.

So, I tracked down the pin assignments in the firmware and flipped the X and E0 pins, and it works! Is it really that simple? I worry I’m overlooking something in my ignorance.