Z won’t move below zero. (RAMPS)


I’m trying to drill a simple hole in my waste board! This is my first job! But the z axis won’t move below 0. I’ve tried changing some settings after reading different threads with no luck. I use a touch plate on z_min end stop and preconfigured marlin from v1.


This sounds like you have MIN_SOFTWARE_ENDSTOP_Z set. The X and Y are set in dual endstop firmware, but not Z.

It can also be set by an eeprom/gcode setting:

I don’t think it should turn on the Z though.

Thanx Jeffeb3,

I have checked this after reading your answer on a similar post. Unfortunately this was disabled in my configuration.h, so no luck there! I did however get the machine to start going negative by setting 0 with G92 command. It seems Z won’t go negative when I home it with the plate and crocodile clip.

Hmmm. That’s not good. I wonder how we change that.

To be clear, you’re doing G28 Z to home Z, and you have a touch plate on the zmin port?

To confirm, you have 0 at the surface and positive is into the surface, right? -Z is away from the waste board.

Do you have yours that way? That seems counterintuitive. I’ve only seen people have +Z go up.

Correct! Might be some constraints in repetier host maybe? Have not found any settings by scrolling the menues!


negative is towards wasteboard. This is logical for me and also the right configuration with regards to the setup guide for the MPCNC. I have thought of inverting, but its not possible to enter negative values in ESTLCAM, so positive values converts to negative GCODE direction when creating the “print”.

It seems inverting this would cause a lot of headache using cam software:)

I had the same “problem” with my cr-10 after mounting an ABL sensor, but was able to go negative by changing #define Z_PROBE_LOW_POINT in the ABL section in marlin configuration.h

I’ll just use G92 and skip the homing of Z for now, but its kind of irritating not figuring out the problem;)

Can you make it go lower with a command: G1 Z-1 ?

That is two people with this issue on a ramps, maybe try my previous release on the firmware. I don’t have a ramps board on a CNC to test anymore.

I guess I set mine up backwards then. Huh. Seems to work fine though. I’m used to the bed moving down for +Z axis on my 3d printer.

If it works for you, then no one can complain:)

Don’t think of the actual motion, consider the result. The bed and head moving further apart is positive, getting closer together is negative. Same result achieved in two ways.

I’ll try with an older version then! Do you have one pre configured?

G1 Z-1 works! But not trough the controls on the diplsay unit or manual control in repetier host!

Reptier will not go negative, unless maybe you enable CNC mode.

Does the crown work?

Under printer settings i have selected CNC router. By crown do you mean the “first print” in your guide? I have not tested with a pen, i went straight ahead to drill holes for wasteboard clamps!

Yes, with any issues you should default to checking with that known good file.

How did you drill the table without going negative?

I can go negative if i dont home z. Sorry if the erlier posts did not make that clear. If I home z its locked at zero and can only go positive. But if i home x/y and do G92 z0 the program goes negative when i print.

I am also able to do G1 Z-xx after homing z, but when running gcode produced by estlcam, or trying to go negative with manual control its locked at the homed position.