Z's out of sync?

After resolving my eeprom vs firmware issue yesterday I wasn’t able to much testing aside from jogging around the router. All axis’s home fine and I can jog each axis around without issue. I can run Z up to 130mm and they stay in sync. I kick off a carve (that same cribbage board generated in Estlcam) from octoprint and the Z axis’s get out of sync. I can watch Z2 begin the drop for the drill operation and a second or two later Z1 starts to drop. This continues until Z 0 seems to have shifted down -5 or more. I end up killing it before it gets too whacked out.

What I’ve checked:
Verified all wiring correct
Checked couplers and verified threaded Z rods and motor shafts were well seated and the grub screws tight.
Thinking it might be a voltage issue increased from 800 to 900
Disconnected the USB to Pi/OctoPi and tried to cut from SD - same results.
Drivers do not get hot nor do the motors.
Ran the job with out the router attached and still had the same issue. I could see the Dewalt plate hitting the surface and lifting the Y carriages as the job ran on.

My setup:
SKR Pro 1.2 /TFT35/TMC5160’s Ryan’s latest marlin Duel endstop LR firmware.

The Skr Pro firmware doesn’t have 5160 support. I’m guessing you made that change already?

Just to make sure, the second Z is plugged into the E1 port, right?

Does M122 (after the issue) show any issues (open loops?).

Does it fail on the test crown premade gcode?

Do you have a fan on the drivers? Are they getting hot?

I changed the drivers to the 5160’s, Z2 is plugged in to E1.
M122 looks good:

Test crown looks OK despite my Sharpie running out of ink:

No fan on the drivers but they are barely warm.

Just to confirm something… In config.h do I need to define the drivers for E0 and E1 if Y2 and Z2 are defined?

No, I don’t think so. They show up in m122.

I have had it work once that ola and olb showed an intermittent wiring issue. They aren’t shown in the M122 and the errors ckear if the drivers disable, so it would have to be after the problem, but before the motors disengaged. The drivers can also cool themselves down by reducing current.

Is it possible the rsense is different for your boards and you aren’t getting enough current?

I guess it’s possible. I have rsense set down to .075 per the TMC5160 guide up on BTT. They worked fine on the SKR 1.3 with the same settings. I don’t hear any skipped steps and am now thinking it might be a binding issue. Going to disconnect the threaded rods and make sure nothings bent and if needed change out my couplers.

1 Like

Removed the lead rods cleaned and relubed them. One coupler is stretched pretty bad so I swapped one from my 3d printer. Currently 90 minutes into the cribbage board carve with no issues. Fingers crossed.

1 Like