Any luck connecting with a Mac computer? Try LCD controller instead?

This is my first post in the forum and I just had to express my thanks to you Ryan for your innovative and inexpensive design. After years of searching for an affordable CNC, you answered the call with not just a CNC but with a multi-tool machine. I knew you would win the innovation contest back in July when I voted for your project. You made us proud.

I purchased the CNC bundle from this site and 3D printed the assembly parts. It took me a few weeks but I finally completed the assembly and had a blast doing it! I’m ready to start testing. I installed Arduino software to my Macbook. I plugged in power to the RAMPS board and plugged the Arduino board USB to the Macbook but it could not detect it. I figured the Arduino board might be generic so I searched and tried installing a driver I found at

Now the Macbook detects the board but Pronterface or Repetier was not able to connect. I tried all the ports the new driver made available but it didn’t work. I could try my very old Windows XP laptop that I have stored in a closet somewhere but I use my newer Macbook on my 3D printer all the time so I never bothered.

I guess I could try looking for other Mac drivers but I was wondering if anyone had any luck on a Mac.

If not, I guess it won’t be a problem if I buy the Smart LCD controller. Am I correct in assuming I won’t need to connect with a computer at all as long as I have the LCD controller?

Thank you for the compliments! I have my fingers crossed for the grand prize this month from boca bearings to put half towards school loans, but I would also be ecstatic to get another 3D printer to ramp up production.

Okay you are the 3rd person now having mac issues. I would love to get this figured out and put it on the instructions.

Where I left off with the last person was this screen.
I know on a mac the default settings are slower. try changing the baudrate and the rest to match. If that doesn’t work I will make a custom firmware to match the mac baudrate and see what happens.


I read about how you built your 4 head design to keep up with demand! You, genius you!

I’ll try experimenting with different settings and there are most likely other Mac drivers for the Mega 2560 that I just need to try.

In the mean time, I ordered the Full Graphic Smart Controller from your shop so I won’t have to connect a computer. Letting a smart controller run the machine is convenient.

I’ll document my Mac experiments and let you know how it goes. Thanks Ryan!

Yes, with one of the LDC controllers you will never need to attach your computer. I have one of the XXL LCDs on my printer and a Full Graphics LCD on my MPCNC and never miss attaching a computer to them.

Awesome. I looked at some video reviews of the Full Graphics and the XXL LCD controllers. They are so many configuration options already built-in! Can’t wait to try it out.

I decided to troubleshoot the connection issue with my Macbook a little later. I couldn’t wait to test out my newly assembled MPCNC so I pulled out my old Windows XP laptop, installed Arduino, Pronterface and Repetier. All of the software could connect and when I jogged each axis I saw the machine come to life! It’s so beautiful! It looks like I got everything wired up correctly on the first try! High-Five everyone!

Okay, so going back to the Macbook connection issue, I think Ryan’s suggestion of slowing down the baud rate is the key.
WatEng’s comment in the blog seems to confirm this:

So editing the baud rate in the Marlin firmware to 115200 should solve it. Lowering the baud rate in Pronterface or Repetier on the Macbook alone wasn’t enough.

When I get a chance, I’ll download Ryan’s latest Marlin firmware beta from his latest blog post, edit the baud rate and see if works.

Can’t you just change the default baud rate in repetier? Much quicker than messing with the firmware.