Aspire Post Processor

Cool. but are you actively using it for your work on your MPCNC?

I am doing the flower right now in foam… really cannot believe how well its running. I guess I didn’t realize that this machine can do those sorts of 3d cuts.

Ok. I should have looked first… I thought you were talking a trial version sign.

So what version of the software do you have and what advice would you give to someone just getting started. Is it worth throwing that much money at it? vs. just using the free software or lower cost software?

I just tried this “Importing Flower Model” tutorial on the free Desktop Vcarve … cannot figure out why it stopped on the finishing mode. I did the rough cut first and then screwed up since I didn’t record my start position so I had to start a new one. The things I have noticed using that marlin_mm.pp file is that when the cut is does it does not return to it’s start position. Also, the test files seem to me that the movement is extremely fast. In foam no big deal but on a hardwood, etc. may results in some damage… either way I think it’s some really good software and should be for the price.

Mike,

Awesome job with the PP for V Carve. I purchased V carve Pro vs 10 several weeks ago and have been looking for a way to edit the PP. I am a complete novice at this. I did purchase the low rider from Ryan and have had some luck with Estlcam but it has limitations for what I want to do making signs.

I did download your PP but I am having a problem downloading it into V Carve as a PP file. I can save it only as a text file and it shows up in the post p file in v carve when I load it but when I go to save the project and open the correct PP fi;e it does not show up.

Any help you can give me to get the new pp saved will be greatly appreciated.

Thanks in advance,

Russ H

@john: Thanks for the post processor for Aspire. I did notice something that i think might be an error… or oversight.

At the beginning of a “run” the CNC is supposed to raise the bit to “Safe Z”. In the PP, this command is listed as: “G1 [SAFEZ]”, but the [SAFEZ] variable only gives the number and not the “Z” command. Thus, if your Safe Z is set at 5mm, the resulting Gcode will become “G1 5.000” and will basically do nothing, resulting in deep cuts. I didn’t notice at first, because I sat my Safe Z to 2mm. and was cutting fairly rough cuts.

I guess the right command in the PP would be “G1 Z[SAFEZ]”.
Also, the marlin firmware as far as I know, does not support G0 as rapid move command… we should probably change the rapid move line in the PP to something like “G1 [X] F80 [Y] F80 [Z] F10”…

If anyone have any other thoughts about this, lemme know :slight_smile:

Klaus.

1 Like

I don’t think that would work, it is one speed per line, so you either separate it (G1 X Y F80, G1 Z F10) or you can make sure the combined move from one point to the next would not violate the max speed you want. Usually a XY move is large and a Z is tiny so the z moves at the same time but distributed over the entire move it ends up moving slow enough.

Not sure how to clarify the second part of that but I can try again if you want to do it that way.

Well, I tested it out, and it worked fine. I did change the numbers though… :slight_smile: I set them to F2000 on the X and Y, and F500 on the Z…
I also accidently forgot to change the G0 to G1, but it didn’t seem to make a difference… Before changing this line, my CNC would crawl slowly to the first point, but now it speeds to where it wants to start.

 

Klaus,

 

Would you mind providing a link to download the pp file you have working correctly?? Thank you

Sure, no problem.

 

Marlin_mm.zip (1.05 KB)

2 Likes

Thank you

Thanks for the post processor. It’s working great for me!Ho Ho Ho!

 

 

1 Like

Had to remove G0 from the post processor to get reliable cuts on my dual endstop lowrider.

Marlin_mm.zip (1.03 KB)

There should be a way to set the speed of the G0, Marlin can handle them it just doesn’t treat them any different (yet). So a Rapid speed usually just has to be set within reason Start at 30mm/s XY and 8mm/s Z. You can work your way up from there.

Looking for help!!!

Just recently upgraded to Aspire from SmartCAM, and the biggest issue I’m having at this moment is the post processor for our Komo VR408 with a Fanuc O-M controller. I had a post processor made for smartcam, but when I read the text in the algorithm for smartcam I don’t see how to transfer that. Is there anyone out there that can help me with this? I’m going nuts looking it. lol

Hey guys,

 

I’ve tried all the different versions of the post processor in here and they are causing the x axis to bind…

If I export the project from aspire to dxf and open it in estlcam it works fine…

Is there something I’m missing?

I can shoot a quick video of what its doing if it helps.

I have the same issue, sorry I cant help with a fix.

What feeds speeds and rapids are you using?

It only causes issues on one axis or that is just the first to move?

I'm stupid. In Aspire when you make changes to the bit's feed rate you need to hit the "Apply" button to make it update the project with the new speeds.

I was using waaaay to fast speeds, the post processor was working exactly like it should.

I’m dumb.

 

Nope. I would say just excited to get to the action, making an idea into reality is always cool as heck! Trust me, this sort of thing will happen all of the time. Glad things are working as they should.

I will mark this as solved.

I know this is a necropost, but is anyone still using this post-processor with success?

 

Edit: Nevermind, I did not see the second page when I looked at this thread on mobile.

Yes. It was just verified again in the post from yesterday.