[Beginner] Holes are too small, but the rest is normally sized

Hello, me and my father (mostly my father tbh) have built the MPCNC, it works fine, but sometimes holes get really weird. Let me explain:

I’m using Fusion 360 to create my parts, and I’m trying to create a better spoilboard. So I made a small piece to try the differents screw sizes (these 2 are very slightly different), which looks like this:

It is for 2 M6 screw, so I made the central hole 6.2mm, and the diameter for the screw head are 14.5mm (left) and 14.8mm (right). The outer side is perfectly fine (it’s like 30.2mm in reality for 30mm on sketches). But the holes, they are at the wrong size. First time I cut it, they were cut really poorly (like only a cross shape, I don’t know why). I re post-processed the file and it worked, the circles are circle as intended. But they are way too small. It’s 5.8mm instead of 6.2 for the small hole, and 12.8 & 13 instead of 14.5 & 14.8 for the bigger ones, which is really annoying. And circles always had a strange behavior since we built this machine. Which uses ramps 1.6.

In fusion, I used 2d adaptive machining for the bigger holes, and 2d contour for the smaller ones and the rectangle shape. Here is a list of all the settings I used (which are almost the same as default):

A simple solution would be to scale up my holes (what I used to do), but now that we’re upgrading a bit the CNC I really want to solve this problem once and for all.
I also tried slowing down the speed using the screen to like 20%, but same result, it’s really weird.
I also checked for the diameter of the drill by simply going down on Z axis, and the hole is the right size (3.175mm) as theoretically. So if anyone have an idea of why it’s acting like that, or any tests I could perform to solve this, it would be nice. Thanks in advance :smiley:

Welcome to the forum!

Have you tried in estlcam?

Are you doing a finishing pass? There’s also a setting for ‘radial stock to leave’. Make sure that’s set to 0 I think Fusion360 puts a value of .1" or .1mm in there by default. There’s another setting for height, but I don’t remember what Fusion360 calls that… set it to 0 also. Hovering over the values will help describe what they’re doing.

Hey ! No, what is this software for exactly ? I don’t really get it

Free CAM software that can take a simple vector image (dxf/svg) and make gcode. Take a look at the docs, they have good guides.

I checked, radial stock to leave was only checked on 2d adaptative machining (big hole), and it’s value was 0.5mm, but not on the smaller ones

I also didn’t found the other parameter

Oh yeah, anorher weird thing, 3 days ago I tried a new plastic sheet by cutting a test piece (holes, rectangles of different sizes) using a 2.5mm drill, and the holes are perfectly sized, i used the 2d contour. So sometimes it works, sometimes not and i don’t know why (it’s not the first time that it works or doesn’t, it’s random to me but i guess there is a reason behind this behavior)

Try cutting your part in pink foam. It could be your z axis flexing while cutting the wood. If the pink foam is the correct dimension, then you need to take shallower cuts or use a smaller step over.

Anytime I have a part not coming out right, I run the gcode through pink foam.

I just tried, and they are the same size as in wood sadly

Estlcam Estlcam Estlcam

I’d like to solve this problem directly instead of using a workaround, it also saves me time learning the software and everytime exporting into dxf (which is very long in fusion 360) and creating all the toolpath

The thing that triggers me is that it sometimes works, and sometimes not, could it be due to my marlin configuration or hardware related ?

I tried a bit, but it goes up on Z axis, moves towards the correct locations, and stops moving
Guess I have to check all the config and post processors

exporting a dxf is as simple as right-clicking a schematic and clicking, “save as dxf”.

It’s doing it in the pink foam too, so that takes out flexing of the machine. It ‘could’ still be loose grub screws on the pulleys, but that issue tends to show up as a more sporatic errors and not so consistent.

It could still be a scaling issue on the settings in Marlin.

If you have the time, you can try 3d printing one of the pen mounts. Mount a pen and draw a 100mm x 100mm square. Measure the square as accurately as possible and adjust the scaling values in Marlin until your machine draws a perfectly dimensioned square.

Did you remove the .5mm radial stock to leave?

When you cut it the first time, you said it only cut a cross. That can happen when something binds.

Which post processor are you using in Fusion 360? Are you using Guffy’s (or the new one based on that… I don’t remember the name, sorry) ?

If you’re using Guffy’s, then try turning off arcs (if it’s on, or on if it’s off).

As I said dxf export in fusion 360 is very long because of cloud conversion (a few minutes long), then yeah I removed the radial stock to leave, I could try to draw a 100x100 square if you want, but the thing is that my test piece with 2 holes is 30x50 (with the 2 holes inside), and this rectangle is almost perfect (it’s like 30.2 and 50.2 also, so almost as wanted, and not “downscaled” as the circles. And finally I’m using this post processor https://github.com/martindb/mpcnc_posts_processor (Arcs are on, I’ll try disabling them tomorrow) :slight_smile:

I agree that estlcam is easier, and I don’t understand fusion, so I can’t really help in a case like this. But… you can’t convince everyone to agree, and it really isn’t worth the friction to try. There are a lot of users who know fusion who can offer some advice. In this thread, just let them work it out on their own.

If anyone is interested in more detail on what CAM is, the software workflow should be a good primer.

I still think you’re doing the dxf export different than I am. My method does not use cloud conversion and the file is saved locally immediately.

Here’s a newer version of the PP you’re using:

Maybe give it a try and see if it’s the PP producing different results.

You can use the Shaper Origin plugin to export SVGs from any face.