Blue LCD screen with mini Rambo but not working?

I ordered the parts to build a ZenXY table a while back, and yesterday I decided to finish it up. I used old guy codings belt routing, programmed the mini Rambo with the Marlin software (Marlin ZenXY ramps 16T LCD 32), plugged everything in around 3am, and the LCD lit up, but only solid blue.

I searched the forum, saw a couple posts of people saying to turn the cables 180 degrees. I’ve unplugged it, swapped cables, plugged it back in, unplugged it again, rinse lather repeat. I just tried reflashing the board, tried all the combinations again, no success. Do I need to flash the board with the LCD plugged in? Am I missing something? Photo of my current situation included, any help is appreciated!


You do not need it connected when you flash it. You can confirm it was flashed by connecting with repetier host and see the version text in the console. When you flash it, arduino should say “upload complete” or a similar message.

You can flip one end of the cables by 180, or swap exp1 with exp2 or do both. So there are 4 ways to connect it. Sometimes the connectors are keyed, so they don’t fit rotated. You will need to remove the key or the plastic part of the socket.

This happens a lot. It will be an easy fix.

Just checked it and it shows the ZenXY, gonna flip these cables around each way till I get some life on the LCD screen (bedside it just lighting up blue without anything).

So I verified it through repetier host, It has three ZenXY software on it, and tried all the possibilities of the cables on the LCD screen, and there is just one configuration where the board will light Up, both cables turned 180 degrees from what they’re normally supposed to be, matching photos of what other people (including the vicious one himself have shown). When it lights up, I can see that all the pixels on the screen are showing… Is there something I can do with the potentiometer? Bleh. I feel like I’m so close and not sure what the heck is wrong haha

This has to be something simple. So sorry if it feels like I’m asking dumb questions. When you rotate them 180, you turn around just one end of the cable, right?

I had to cut the tabs off at the LCD cable end connectors, and flip them around. Both cables had to be flipped around. Then it came to life. I use the RAMBO 1.4, and the keyed tabs at the board were fine the way they’re supposed to be installed. As someone said to me, there’s only 4 combos you can try, one of the 4 will be the right one lol

I should mention, this was exactly what it did to me when I was building mine. And here’s the thread with the answer to the problem I was having. Look around 12 days ago.

1 Like

Aren’t there actually 8 combos? (AB, A’B, AB’, A’B’, BA, B’A, BA’, B’A’)

Glad you got it working…


I thought it was but I’m sure its infinite nothing I did worked till I realized I had the wrong display after a hour now all is well here too

Detailsssss lmfao

I know I’ve repeated the four combinations line. And was wrong. It’s four combinations per cable. 2 cables * 2 positions * 2 orientations = 8 permutations.

The cables are going to go the same way though.



Alright, if I hook up the mini Rambo with the LCD screen plugged into it, but nothing else plugged into the board, will the LCD work?

I hooked just the board and LCD up to repetier host, and it shows The Marlin ZenXY software is on the board. Gonna try it again when I get home, I haven’t looked at it in a couple days due to Corona virus chaos.

None of the other things attached to the board (which should just be the motors, and endstops, right?) should affect if the LCD works or not. If you can connect to the ZYX with RH and get the version, then you should have everything checked out until you get to the cable of the LCD.

It may be something wrong with the LCD too. I know they sometimes end up getting a little smooshed, or having really crappy solder jobs on the back. But that is less than 10% of the issues (the other 90 are the cables in the wrong way).

In a new development, when plugging this into the repetier host, it comes up with:

Error: Printer halted. kill() called!

And has some errors in the log… Pasting log in following post

16:03:07.746 : Printer reset detected - initializing
16:03:07.746 : start
16:03:07.746 : echo:Marlin 421 bugfix-2.0.x
16:03:07.746 : echo: Last Updated: 2020-03-19 | Author: (V1 Engineering, Ryan, 421)
16:03:07.746 : echo:Compiled: Mar 22 2020
16:03:07.746 : echo: Free Memory: 3330 PlannerBufferBytes: 1456
16:03:14.600 : echo:V76 stored settings retrieved (640 bytes; crc 47626)
16:03:14.866 : FIRMWARE_NAME:Marlin 421 bugfix-2.0.x (GitHub) SOURCE_CODE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:ZenXY EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
16:03:14.866 : Cap:SERIAL_XON_XOFF:0
16:03:14.866 : Cap:BINARY_FILE_TRANSFER:0
16:03:14.866 : Cap:EEPROM:1
16:03:14.866 : Cap:VOLUMETRIC:1
16:03:14.866 : Cap:AUTOREPORT_TEMP:1
16:03:14.866 : Cap:PROGRESS:0
16:03:14.866 : Cap:PRINT_JOB:1
16:03:14.866 : Cap:AUTOLEVEL:0
16:03:14.866 : Cap:Z_PROBE:0
16:03:14.866 : Cap:LEVELING_DATA:0
16:03:14.866 : Cap:BUILD_PERCENT:0
16:03:14.866 : Cap:SOFTWARE_POWER:0
16:03:14.882 : Cap:TOGGLE_LIGHTS:0
16:03:14.882 : Cap:CASE_LIGHT_BRIGHTNESS:0
16:03:14.882 : Cap:EMERGENCY_PARSER:0
16:03:14.882 : Cap:PROMPT_SUPPORT:0
16:03:14.882 : Cap:AUTOREPORT_SD_STATUS:0
16:03:14.882 : Cap:THERMAL_PROTECTION:1
16:03:14.882 : Cap:MOTION_MODES:1
16:03:14.882 : Cap:CHAMBER_TEMPERATURE:0
16:03:14.882 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count A:0 B:0 Z:0
16:03:14.882 : Count A:0 B:0 Z:0
16:03:14.882 : echo:DEBUG:INFO,ERNORS
16:03:14.882 : Begin file list
16:03:14.897 : End file list
16:03:14.897 : echo:Unknown command: “M80”
16:03:14.897 : Error:Line Number is not Last Line Number+1, Last Line: 11
16:03:14.897 : Resend: 12
16:03:14.913 : Error:Line Number is not Last Line Number+1, Last Line: 11
16:03:14.913 : Resend: 12
16:03:14.928 : echo:DEBUG:INFO,ERRORS
16:03:14.928 : Error:Line Number is not Last Line Number+1, Last Line: 16
16:03:14.928 : Resend: 17
16:03:14.960 : Error:!! KILL caused by KILL button/pin
16:03:14.960 : Error:Printer halted. kill() called!

There is a button on the lcd. If you press that, it will stop everything. So this is still isolated to the screen or the cables.

So This whole time I was putting the LCD 32 software on the mini Rambo. Right now I Just tried loading the ZenXY software that didn’t have “LCD 32” at the end of the title aaaaaaand… The screen is a bit pixelated, but I can actually see information on it!

1 Like

When I had that kind of display it was a bad connection on the wire

on a 3D printer that I fix replacing the board I had that same issue and I increase “ST7920_DELAY” in the firmware (configuration.h)
Also look at this … good information here.

Did the delay think mentioned in the last post and success! Made a couple wipe and circle files and am in the process of smoothing out my baking soda. I’m sure I’ll have a ton more questions in the future, but so glad to see this thing going now!!