Can't connect new RAMBo board to Repetier

Hey guys!

I got my RAMBo board in my kit from V1 about a week ago and just finished assembly of the MPCNC and can’t get any of my computers to connect to Repetier. As I understand it, it should have the firmware ready to go. I got all parts from V1, and I’ve tried Mac (OSx 10.12.6), Linux (lubuntu 17.10), and Windows (Vista and 7). I got Arduino and Repetier software running on all these platforms, and the Arduino software could see the board. As a last effort, I tried to upload the firmware to the board with the Arduino IDE, but I got timeout errors. Any help would be appreciated :slight_smile:

Are you sure the virtual port opened on the USB connection is the one you are trying to open? I can’t help with the Mac or Linux machines, but on both the Windows machine if you open Device Manager and go to ports the correct one will appear when you plug the USB in. By default Repetier-Host does not open the correct port (IIRC it tries COM1 and the port is usually COM3 or COM4).

1 Like

Look to see if a driver is needed on windows 7, its getting up there in age. 8, 8.1 and 10 should not need any driver other than what arduino provides. MAC and linux are not my specialty, but should work and do for most.

1 Like

How are you powering it? The ftdi chip gets power via USB, but the Arduino needs the power supply on. At least the mini does. You’d see a serial port but never be able to connect to the board of you were only using USB.

In Linux, the dmesg log should show details about the connection when you plug it in. I’ve never needed drivers for Arduinos in Linux, just board packages in Arduino when reprogramming. I don’t own a full size Rambo though.

@Jeffeb3, for the win! I was supplying power to the motor circuitry but not to logic. Do I just bridge the positive pins for powering the motors, or do I need to bridge positive and negative pins?


Both positive and negative. If you don’t do the negative, it might still work, but the current will be finding some other way to ground, which might not be spec’ed for that.

1 Like