CNC Firmware - RAMBo Build - Always comes up 3D Printer


I’m putting together my LowRider 2 and am to the point of connecting the RAMBo board to the steppers. I tried to connect the LCD controller but it wouldn’t give me any display output. I thought there was no software so I downloaded Marlin FW, I built it and flashed it. The problem ended up being a cable issue.

Now, the FW thinks it is a 3D printer and I haven’t been able to configure the FW to make it a CNC. I went to GIT and pulled down V1CNC_Rambo and have configured it for RAMBo but it keeps coming up with 3D printer. How do I configure the FW to make CNC?

There is no difference, and I am not really sure where or what says 3D printer? My firmware has extruders disabled. Use my firmware and no changes are needed.

1 Like

When you say extruders disabled, is that the same as #define EXTRUDERS 0?


I have started over with a untouched configuration.h, configuration_abv.h, and version.h. The only changes I made are:
#define EXTRUDERS 0

Now there is no output on the LCD display.

Why not just use my firmware and make no changes? What are you trying to do?

I tried the downloaded firmware from GIT. I got it to compile and loaded it into the RAMBo. There was no menu. I’m just trying to get the system to work as if it was out of the box. Nothing more.

I’m sure that I’m the problem. I probably got the wrong code base. But, I did try and follow the directions on this site.

I started completely over. I followed all the steps as you have laid them out. It worked!!!
I knew it was my fault because your site has always provide the best information when I needed anything for my 3d printer.

Sorry for the inconvenience!!!
Thanks for the help and support


Good to hear!