Converted to series wiring - steppers shudder when homing

Should definitely check your voltage if you are unsure where its at… 90mm/m is really slow. Do you mean 90mm/s? that would be a fast home.

So I’ve verified the configuration.h file and the feedrates were too high for series. I think they were at 150 mm/s. So I’ve changed them all (see below) to 60 mm/s. Much better.

#define HOMING_FEEDRATE_XY (60*60)
#define DEFAULT_MAX_FEEDRATE {60, 60, 8.5, 25} // (mm/sec) MPCNC

I also changed the Travel Feedrate under Printer Settings->Behaviour in Repetier to 60 mm/s or 3600 mm/m (the pic is an older one disregard the 6000, it’s at 3600 now).

I did notice that sending a G1 does not produce the 60 mm/s right away. A G0 does. However, if you add F3600 (or a higher number) the G1 move speed is limited to the DEFAULT_MAX_FEEDRATE.

Home moves do follow the HOMING_FEEDRATE_XY setting just fine.

So now, on to the Pololus. For the X and Y, each having their motors in series, what should I set vRef to, assuming that’s what I should be doing ? I have the steppers and drivers from Vicious1.

Anything else I should look at ?


I’m still running mine at .7

Ya, series steppers are working awesome. No skipping at all. Set to 3600 mm/min max. Was able to cut 3mm depth at 3600 mm/min 30000rpm with an 1/8 down cut bit. Cool. Just for test purposes of course… :slight_smile: