detecting false hits with the endstops

I have just fixed the one endstop that was catching on the rubber belt. Now the machine will not let me move backwards toward the negatives in manual mode oher wise it says the end stops have been tripped. None of the endstops have hit anything at all. Is this a wiring issue?

What does it say when you run M119 testing each switch?

How do issue a m119 command? Via arduino? I just put the marlin software on the board.

Sorry, How do I issue a M119 command I put on the right program and “flashed”? it to the board. Because my board can no longer connect to the Repetier-Host. And how do I enter this M119 command? I there isnt much info on how to enter in said command.

M119 is done from repetiers command line box, or other command line.

Ok so I put extra code on with Arduino 1.8.9 (by accident (did this before asking that how to enter in that command and cannot seem to reinstall that firmware with a newer version of Arduino as I do not know how to remove it but it said it was successfully uploaded ) Repetier wont connect to my board and I cannot issue a M119 command via the G-code box. It says there is no connection and that it will force start then when trying to input a command Saying that there is a communication timeout and reset send buffer block. I have tried powering down the board to no luck. Do I need to entirely reflash my Rambo?

Yes, probably best just to re-flash.

Ok is how do I reflash do I have to remove any thing that I have done from the Rambo? Is there a link I have read how to flash firmwear and I do not see how to reflash. And when I do reflash for my Rambo (that has endstops) do I just need to reflash with t firmware that is under the endstop instructions.


I am not sure what you mean by endstops, if you are using individual wires and endstops you use the dual endstop firmware, if not use the other one.

Ok thanks for clearing that up I have just tried it again following the process for flashing and to no avail I still get the same error of not being able to compile and exit status 1. Picture shown is the screen that I get.

Expand the lower window, there is a lot more to that error. Scroll it all the way to see the first few errors that are there.