Determining job starting point.. struggles

just want to start out by saying thanks again… to anyone and everyone whos helped me here especially ryan!! COMING from zero experience in cnc designing and wood working ive come a long way thanks to all of the inspiration here!!!

ok after pulling all my hair out im here again lol

i feel like i should start from the top to show exactly whats going on to help keep me out of your guys hair!!!

heres my table 4x8 ft

i have dual endstops setup and endstops on x and z
(im pretty sure my end stops are longer than my table is length wise though)

heres what im working on …

ggarden123456.gcode (1.6 MB)

i made it in “photoshop” used “vector magic” to vectorize it into an svg. used “inkscape” to create the dxf.

then into estlecam to trace the paths (i chose to carve it) and create the gcode for repetier host

and here is where im stuck

i have the machine homed to the endstops and i want to begin the cut at a certain place on the table
(but i have no clue how to do that) (or which program i need to do it from) lol

as of now ive been trying to use the
(G92 X0 Y0 Z0
G00 X0.0000 Y0.0000 Z0.0000 F2100
G00 X0.0000 Y0.0000 Z5.0000 F500)_

but the machine still moves up first away from where i set it and doesnt plundge down before it starts moving around like its doing something lol … it just moves to a different position to start the process pretty much
(( should (F) commands in the gcode be ignore when using for milling/cutting? ))

also i created a smaller file of the gcode im ultimatley trying to accomplish cutting .
im using just a small portion of the total and it still says it will take 4 hrs lol … i have to be screwing something up! im using the skinny 1/8th carving bit i order from here w the 45 degree angle
heres that smaller gcode
outer left.gcode (226.6 KB)

any help is GREATLY appreciated!!!

1 Like

So have you tried just the Crown Gcode?

copy this to your machine and see what happens.

1 Like

Some comments:

  • I second Riley’s suggestion that the place to start with your machine is with the pre-made crown g-code file and a pen. This will allow you to test your machine without having to be concerned with any tools/authoring issues.

  • Using a G92 is how the majority of us using MPCNC machines establish the home position to start the cut. If you care about the squareness of your machine, you home the machine first and then electronically move the machine to the place you want to be the origin for your cut. Note the relationship between the origin (0,0) and your project is something you establish in EstlCAM when you author your job. The G92 can be automatically inserted by either EstlCAM or Repetier-Host.

  • When I look at your g-code file, the movements are very slow. I suspect you are authoring movements in mm/s when Marlin expects movements as mm/min.

  • The move up at the beginning is expected and is a clearance move. Looking at the file, the g-code does not move below 0 on the Z, so the fact that your router does not plunge is an EstlCAM authoring issue. You are not telling it to plunge.

  • I don’t know if “vector magic” does anything special, but Inkscape does a decent job of tracing images, so maybe you can remove a tool from your software pipeline.

  • Your first project (the one in the attached g-code file) looks really cool, but is too complicated for the first use of your machine. After successfully doing the crown test, start with contour cutting some simple, non-symmetric shapes. This will allow you to shake out the issues in your machine and software pipeline.


Screenshot 2022-07-18 101446

There is no g92 in your code, you need to add it to the start gcode section in estlcam.

It will show up in line 5 or 6. Currently, your gcode says, “from where you are return to home on each endstop.”

F6=0.1mm/s that is far too slow.

Have a look at estlcam setup and verify all the boxes, it looks like you missed a couple. Then take a glance at the milling basics for the starting gcodes.

You are close and this is an excellent post with all the info to be able to help get you there.



i already did my crown test
but like 4 months ago :(… and it did just fine… although i had a sucky pen lol but it still worked out

so im going to take the rest of the day to digest and fix/work on everything you all left for me to look at … and ill report back!!! …

thanks again

@vicious1 Thanks for creating the Estlcam docs.

Read the docs a few times, but I ran into similar issue.

Problem/cause: Gcode created by EstlCam I downloaded yesterday does not start with G92 0 0 0

Which Estlcam setting would generate gcode with G92?

Workaround: Currently, I’ve configured Repetier manual control button 1 to run G92 0 0 0 script. I click on the button 1 script before kicking off a job.

Also, the EstlCam doc image shows arc setting enabled, but this results in crazy visualizations in Repetier. I’ve been deselecting arc setting in EstlCam to work around for now. Guessing that results in poorer quality curves, larger gcode sizes.

1 Like

Milling Basics - V1 Engineering Documentation This goes in the starting gcode section in the estlcam settings. There are sections for start end and tool change. Poke around a little more.

Texts, tabs shown in that picture


Cheers! My penance for not reading milling thoroughly will be to contribute edits that may help folks.

1 Like

Nope, my fault. I need to add that to the milling basics page. Never realized it is missing. My apologies for the lack of a more clear path.

Please don’t apologize (unless you’re british as well?), I continue to be blown away by this project, and the years of effort, by many regulars, that have gone into creating and growing this community. Cheers!

1 Like

ok im back!!! and im finally understanding the different codes… and the reason i was having such a hard time getting everything correct is because the machine is interpreting things kind of backwards

the machine homes everything to the correct places…

it also does the correct movements when i use repetier host … per the v1 documents

i cant figure out whats going on … it has to be something simple

when i do the test crown it does the crown its drawn with the wrong orentiation
same with any other gcode i try

i attached a pic

have no idea why if it homes everything correctly
even when i home each axis individually they all home correctly

in repetier host it shows the drawings going the correct direction but the output to the cnc doesnt match if im saying it correctly

im stomped

how it looks on my repetier host also

I think you may have wired yiur x steppers to y drivers. Verify!

(Oh and obviously the other way too)

In the as-designed configuration, the Y axis is the long axis.

This is sometimes a little confusing, because we tend to stand “beside” the LR where the control LCD faces.

As such, the home position and your crown orientation make sense, and are what I would expect.

This is a diagram from the LR2 that I used to explain the axes to someone else, but the LR3 is the same.


Ah haaaaaa… :smile:
I have just entered the matrix…

For some reasin my brain is wired the other direction.

So i flipped the design
Edited the gcode a bit

And i cut some foam. ( horribly lmao)
But it was amazing watching it come to life

This was an amazing journey so far
And there are some truly great and creative minds here

Im so appreciative of everything and everyone here
Thank you so much…

Issues i noticed right away… It noticed my y rails bend a bit which make it cut a bit deeper on one end. Is there a quick fix?

1 Like