Estlcam lifts to surface before EVERY finishing pass

I just finished my first MPCNC build. I ran the test crown and some of my own drawings through estlcam just fine. I’m moving onto foam and created a grid of test cubes. I’m using the settings from “Estlcam Basics” and “Milling Basics”. I put a path around each part, selected them all and applied my only tool as the “Finishing tool” with a 0.5mm “Finishing allowance”.

The gcode saved by estlcam added “G00 Z0.0000 F480” between every single finishing pass, so it sends the router to the surface of the part adding so much time to the cut. I would like to remove this if it’s not necessary, preferably by configuring estlcam and not manually removeing them from the gcode. Any advice or suggestions on eliminating these extra moves?

Thank You greatly!

I haven’t seen a setting for adding or removing that. On a longer job, I don’t think you will notice as much. If it bothered me, I would use a good text editor like vscode to search and destroy the lines. It would take less than a minute.

Thanks for the response. I guess I’ll manually remove it from my short jobs.