Estlcam setting starting height?

Hi guys. I made a little thing to zero my z axis, out of a 6mm thick piece of aluminum. My question is. In estlcam do I put the 6mm in toolpath properties where it says start height? Also if I’m carving a sign for instance do I need to do that for each letter carved or just the first one? Thanks for any help.


you set the desired depth in the “Toolpath depth” field (for each toolpath - but it is possible to select multiple objects at once).
“Start level” is only interesting if a toolpath starts below the actual part surface.

(Get a bit of fine, dense styrofoam like roofmate - this is very useful to play around without the risk of breaking tools)


Thanks Christian. I think I wasn’t clear with my question. What I am asking is this. If the starting position of the z axis is 6mm above the work piece how do i tell estlcam that so I’m not milling into the air above the piece?

You don’t have to worry about that part. When you set your Z height, which should be just touching the top of your work piece, the router will just move back to the zero position from whatever height it starts from.

Yes but I’m not starting mine touching the work piece. I have a 6mm piece of metal on top of the work piece and then I lower the z axis until it touches the metal. That is my zero point. Because I have a dust show on mine and I can’t physically see the tip of the bit I’m using so I have to use this way. When the bit touches the metal piece it completes a circuit which turns on an led and then I know exactly where the bit is without being able to see it. But estlcam thinks I am touching the work piece when I start milling so I end up with the machine making all the cuts into air above the actual work piece.

Set the clearance plane to the thickness of your touch off. Set your start “at clearance plane”.

Thank you Vicious1. That is the solution I was looking for. Finally now I can do some real cutting. Woohoo!

Well I gave that last suggestion a try and it’s not the answer. Clearance plane is for how much the machine is raised before it moves to the next cut. So it can clear things like clamps that might be in the way.

What option did you use for the setting in ESTLCAM-setup-basic settings-cnc program start?

How did you do it, your exact workflow?

You should be able to home the machine with your touch plate @ Xmm thick, Then make your program with estlcam set to cnc start “above origin” or one of those options. I do not use endstops, but it is very possible, I think you just have the setting wrong. It is how a touchplate works. So maybe some more details, so I understand what you have tried.

Or give me a screen shot of your setttings.

Under tool path properties I changed start height to the same thickness as my touch plate and it worked great. Only problem I have now is that the motors missed some steps and things got a little out of position. But I think what happened is the dust shoe ran nito one of the clamps a little and that caused it to skip a little. Still I’m pretty happy with my first real carve. Awesome machine. So much fun I fear an addiction starting. lol.