ESTLCAM works, nothing else

Hi all,

I’m a proud owner of a MPCNC now but veeeeery new to DIY CNC/3DP, so please bear with me here if I’m being stupid…

I had several Arduino UNOs flying around, so I just ordered a CNC shield with DRV8825 drivers from Amazon to get started. I managed to connect everything correctly and was able to control all three axes in all directions with ESTLCAM. Very happy so far.

As a next step, I’m trying to print the crown but fail here. I can start AND connect to Repetier host. But when trying to manually control the CNC, it says “2 command waiting” and nothing happens. After a while I get a “Communication timeout - reset send buffer block”. I tried different things and googled a lot but couldn’t find the answer to my problem. Please can you push me to the right direction?

Best regards,

Can you tell which firmware is on the Arduino? It look like you flashed firmware from ESTLCam and that firmware only works with ESTLCam.

1 Like

That is correct. Again, I’m very new to this and also thought about that but wasn’t sure if that was the case. So one of the “different things” I tried was to compile and upload Marlin. But that always gave me the error message that a Arduino Mega (I assume with a Ramps shield or so) has to be used. I went through the different options in boards.h but none of them seem to be correct for my solution with UNO and a simple CNC shield. Some more googling brought me to GRBL. I compiled the latest version and uploaded it to my UNO successfully. After that, I didn’t get any timeout messages in Repetier Host but lots of “error: Unsupported command”. What kink of firmware would be the correct for my setup?

Did you choose GRBL as language in ESTLCam? Also use another sender like Universal G-codesender to send the code to your board.

1 Like

I don’t think repetier host works with grbl. You can use estlcam or universal gcode sender.

Most of the instructions are focused on getting started using marlin, not grbl.

1 Like

Many thanks. Universal Gcode Sender (UGS) is working with GRBL. I’m still not able to print the crown but I can now continue my debug from here.

I have another newbie question please: If I understand it correctly, my DRV8825 drivers have 32 steps which were configured using jumpers on my CNC shield. Now if I move 1mm in UGS it moves a lot more than that. I assume if I set my firmware settings according to that it would. I just found these settings in UGS (attached) picture. Is there any page that would explain which setting belong to my setup and which settings are recommended in general for MPCNC?

If you are using 20 tooth pulleys, the X and Y “Travel Resolution” should be 160. You can find a great calculator for pulleys and lead screws with the following link

16T pulleys are the recommended, and with 1/32 microsteps it would be 200 steps/mm. Z should be 800 steps/mm with a 4 start leadscrew.

Here a printout of my GRBL settings (Ramps)


Thank you all!

With all the comments above and further studying on the subject I believe I understand now a bit those settings. My movements are now correct.

I still cannot print the crown GCODE created with ESTLCAM since it seems to be incompatible with the latest GRBL version, at least this is what I understand after googling the error message for a while. I will keep debugging and keep you posted.

Thanks again,

1 Like

Never mind, problem was sitting in front of the monitor. Finally, I also have the crown printed :slight_smile:

Issue was that I had forgotten to uncheck “Use arc commands G02/G03” in ESTLCAM. After that, my gcode had only G01 commands which worked like a charm.

Many thanks again for your support and this great project!