Firmware upload problems

I am still waiting for some pulleys and Lead screws, but decided that I could go ahead with the firmware upload.

I have a mega 2560 board and a Ramps 1.4

I downloaded Marlin-MPCNC_Ramps_T8_16T_LCD_32stepfrom Github and unzipped it. the marlin .io file changed to an arduino file on unzipping. I worked theough the instructions and when I came to use the .io file, a new arduino window opened. But from this window, the firmware appeared to compile and upload successfully.

When I plugged in the LCD (using the power supply), nothing happened. Then I connected through USB and the LCD lit up. I reversed the cables and it again went dark.

At this point I decided to connect my board to the motors and ran Repetier host. Repetier appeared to connect okay, but I couldn’t move any motors.

I will attach the log from repetier.

Please help!

 

 

oct-3-test.txt (22.2 KB)

That log is so helpful! How did you save it?

The flash defintely worked. You cam see in the log that it has Ryan’s firmware on it. You can also see it thinks it has an lcd.

Can you check your power? USB alone won’t power the motors. There are two halves of 12V power and one side is only for the bed.

On the lcd. There are 4 ways to connect the wires. You can swap them, like you tried. But you can also rotate the connectors. None of the 4 combos hurt the lcd, but only one works.

1 Like

jeffeb3 Thank you for another reply to one of my queries. I connected the power supply and connected to repetier through USB. Before I tried moving the motors in repetier, I noticed the LCD was displaying the boot screen.

 

I then worked through the menus on the LCD and successfully moved the X axis motor.

 

My neighbour was over for a bit last night and suggested that the usb would not be enough to power the motors. I rejected that advice bcause I can run my 3D printer from USB.

Back to the LCD, I only have two ways to plug in the cables since there are tabs and slots on one side preventing a rotation to work.

Again, thanks so much for your help.

I’m not sure the root cause, but this happens all the time. You can flip the plugs on either end, so if the ramps isn’t keyed, you can do it there. Otherwise, on the LCD, you can just pull the plastic shroud off and the plug will hold onto the lcd pins just fine. I used some flush trim cutters to just cut the key off of my cables.

I have now set the potentiometers. My calculated value was 0.77. They vary from 0.77 to 0.79, so that should be fine.

 

I currently have the 4988 stepper drivers installed on the board. They are only 16 step rather than 32 step. Will that cause any problems with the 32 step firmware?

 

 

You’ll just need to change the steps/mm, since it will take half as many to move the same distance.

So it will change from something like 200, 200, 800 to 100, 100, 400.

You can change it in the firmware here:

Or you can change it with M92:

http://marlinfw.org/docs/gcode/M092.html

Just be sure to save those changes with M500.

What printer do you have? I haven’t heard of any that don’t have their own power plug. You need 12V to move the stepper motors, and USB only has 5V provided.

1 Like

Bill, I might be wrong about my 3D printer. It is a Tronxy P802MA clone. There is a jumper on the Melzi board to set it for USB or Power Supply (I think). But it has been a long time since I played with this setting and think I must have it wrong since I don’t think USB could power all the motors and the heating. required.

 

They all have 5V to power things like the processor, the endstops, screen. Then they have 12-24V or so for the motors, heated bed, fans, hotend. The 12V can power the 5V stuff.

Some boards, like the ramps and the melzi with the switch in usb mode, can power the 5V rail from USB. So you can power the processor and flash new code without the 12V being on.

The rambos, and the melzi with the switch in the other position can only power the 5V from the 12V. I think they do this to protect the computer from the printer and the printer from the computer.

I havent seen a printer run the motors off of usb, but it should be possible. You’d be underpowering our big motors.

Way underpowering… USB 2.0 is rated to supply 500mA (2.5W), USB 3.0 gives 900mA (4.5W), USB 3.1 is the same as 3.0 for devices. When used for charging only (no data) 3.0 can provide 1500mA (7.5W) and 3.1 20A (100W). All this is at 5VDC. If the have perfect power conversion (not possible) that 100W gives 8.3Aish of 12V. I’d say that means if you weren’t using the port for data and you had the USB plugged into a 31 charging port you could just run the steppers on a 3D printer, no hot end, not bed heat.