Help!! Connection problems with repeteir

OK so when I connect my arduino with my ramps board to repeteir it connects fine, but as soon as I plug in the power supply it will come up with an

The connection failed with the following error: A device attached to the system is not functioning.

This is the board and ramps im using.

OSOYO MEGA and Ramps 1.4 board

Its loaded with the marlin firmware from this sight.

You are not using the barrel jack are you?

What would be the barrel jack? I’m not sure what the barrel jack would be.?

Im not using the barrel jack. I cut the wires and hooked them up how they are supposed to be on the ramps board.

Those are different drivers with a different current setting and step rate did you account for that?

Does it work with just power and the screen? does it work with power and usb if the screen is not connected? The screen can be the issue as well. It is hard to say without you telling us everything you have tried. It took me a long time to find a decent vendor of these boards and I still had 9 bad ones out of 50 that needed to be replaced this last small order.

I have a new board in the mail right now. I am try and move away from the ramps stack soon.

OK so this it what we are doing.

Using a Osyoo Mega 2560 arduino with ramps 1.4 board using Drv 8825 drivers. Because we didnt use the whole kit. Also we are not using the lcd screen as we just use the computer software because all we are using it as is a cnc router for now.

Power supply 12v 5 amps

Try it with the screen and make sure it works. It looks like either you don’t have the drivers installed or it isn’t on com3, you can change it in repetier.

So this happens when I plug the power source into my board my LCD Screen goes almost white and Would that be whats throwing everything off, because It connects fine and everything until I plug in the power Supply

Link to the video I made that shows this problem

Well neither of those worked.

What happens when you only plug in the power supply, there is no reason to have both.

You should really put up some pics with it all connected.

At the same time it sounds like you got bad components, you have had nothing but issues. Return them and try again.

It still turns white I mean I can barely make out what its says on the screen so not completely white.

What happens if you turn down the contrast knob? The little white potentiometer.