Help with mpcnc

I purchased a kit about 6 to 7 years ago i think and i never put this mpcnc together until yesterday. Yes i know this is crazy lol. The issue i am having is i got the ramps board that was preconfigured back then and the kit came with the 8mm rod instead of the lead screw and the parts i printed are for the leadscrew not the 8mm rod. i can not seem to find the firmware for the leadscrew(the one in the link from the website keeps giving me an error code) or the printable parts for the 8mm rod i was wondering if you could possibly provide me the links to both options please.

You can use this one, but you need to change the Z steps to 4535.44 Also remember to not try to move the Z axis faster than 8.4mm/s.

A T8 lead screw is highly recommended. Turns out we need the speed more than the mechanical advantage.

1 Like

So download this file then in the configuration h file just change the z steps to 4535.44? (How do I keep the z axis at 8.4mm/second?)

I believe you change the bolded parameter in the following line in Configuration.h:

#define DEFAULT_MAX_FEEDRATE { 120, 120, 8.4 , 25 }

1 Like

I thought we had a V1CNC ramps configuration.

Nope, not sure how we missed it. dual in both places but no regular.

Is that because we missed it, or because we thought the dual would work for serial? I think maybe it started as the first and ended as the latter :slight_smile:

1 Like

I just finished rebuilding the mpcnc after printing all the wrong pieces the first time now i have the right pieces and it put together. just download this file with the 2 changes listed above. I hope it works well, i will let you guys know, thanks for the help also

well its not working the lcd doesnt show anything but a blue screen. it did work on the original board that came with the kit though the only thing that was wrong on there was the lead screw. not really sure whats going on

disregard the post above the arduino mega board was bad tried a different board and it worked

1 Like