I don't get the gantry perpendicular

Hey I have the same problem with my mpcnc like a lot of you. I don’t get the gantry perpendicular. ? I already reassembled it multiple times. Don’t know get better. If I cut squares, the are not rectangular. It is not drastic on smaller cuts. But on bigger cuts it gets worse. Is there maybe a way to tune everything a little via software?

That is a very broad and vague question, have you tried the FAQ’s and build tuning instructions?

Maybe some pictures of what you are using would help, and what firmware are you using?

Most importantly how do you start a project? You can not drag the gantry around and expect it to hold itself square, some care needs to be taken, depending on your firmware.

How far off exactly is it, is this consistent?

1 Like

Not directly, but my mpcnc I assembled a while and I reassembled it a yesterday. Is that what you mean with the FAQ part ?

Yes, I that’s what I do. Maybe that’s the problem, but how this dependent to the firmware ?
I use Marlin-MPCNC_MRambo_T8_16T_LCD.


Please see the pictures . Side length is 500mm.

Okay, is the frame square? You can pull the gantry out of square by moving it by hand. I have physical stops that I start my machine up against to keep the gantry square. Once it’s powered, it stays square.

1 Like

Makes sense!

Can you explain more details how you did that. Thats also something what I am looking for…how to lock the steppers? I have read a lot forum posts, but no G-code I found worked.

I just pull it to the stops and send a g92 x0 y0. Any movement will power the steppers after they’ve gone to sleep. On my machines one stop is an electrical end stop, the other end is a physical block. I just measured the distance the end stop side was at after homing, then put the physical stop the same distance. If it’s not touching the block after I home that axis, I can turn the stepper pulley by hand to click it over the one or two clicks it’s ever really off. If that side hits first, it just skips a couple steps. You can do the exact same thing with physical stops, just pull the carriage tight and power the steppers.

1 Like

ok thank you. I will try that. Which physical endstop you use ?

I’m using Ryan’s endstop mount without a switch on it.

1 Like

I have now tested the electrical endstops (single). But Is it possible, that steppers are locked after hitting the endstop? And second, If the CNC hits one endstop, it stops directly without testing the other axis.

I home one axis, then the other, never hit the home button, it will try to home the z, which doesn’t have an end stop. The other end of the x and y will stop, but if they’re not against the physical stops, you need to manually move them. The steppers will stay locked for as long as the firmware is set for, which I think is something like 10 minutes.

Ah ok. Yeah I unplugged the the Z axis.

Ok, I would do it like this, if I get it right. Home with M206 X1 (setup home offset in Marlin), than move the manual 1 mm back (now steppers are locked), than push the other side (by hand) to the physical endstop. Do the same for Y.


1 Like