Inconsistant Cutting on New MPCNC Unit

I have a few items that I am unsure as to what is causing the problem.

The first is a scaling issue, when the DXF file is imported into Estlcam it is correct in regards to size, at least it appears to be.
When the g code is generated, saved to the SD card and printed out via the graphic smart controller it is slightly smaller than the intended cut.

The second is an inconsistent cutting path. When the second pass is made it does not always line up with the first pass path, but the third pass will line up on the second pass.
As can be seen in the pictures that the further the cutting gets from the origin the more off the cutting is.

The third item I noticed was that when the cutter returns to the origin upon the completion of the cutting it does not line back up in the X direction.

The fourth is the circles do not always cut in a perfect circle, at times they are out of round.

I have tried cutting from 2 different files by making different g codes and it does the same thing with both files.

As far as square the tubes are within 1/16" when measuring on the diagonal
I have been searching and really can not find a specific calibration process, so I am not sure how to perform a calibration and if it will help resolve my problems.

Other than these 3 items this thing is great and I am looking forward to making a lot of aircraft parts.

The frame setup is a 48" X axis x 24" Y axis frame with 3" tall legs


Cutting and rapid speeds?

What parts are you using?

Exactly how far? That should point to the issue.

You should not need to other than making sure you are square before starting each cut depending on what you are using but your question is pretty vague as to build details (dual, no?), steppers, control board, spindle?

The MPCNC is from a kit that I got from V1 Eng. and it consists of:
Controller board - RAMBo 1.4 (firmware installed by V1)
Interface - LED graphic interface controller for running G code
Steppers - not sure of specs, they were what ever V1 provided in the kit
Printed parts - self printed from file downloaded from thingiverse MPCNC for 23.5mm (3/4" EMT

MPCNC setup:
work area of X axis 36", Y axis 13" Z axis 2.87"(minimum height)
48"X axis rails, 24" Y axis rails
2D drawing drawn in AutoCAD LT
G code generated by Estlcam
Rapid Speeds:
X/Y 2100 (Estlcam setting as recommended by V1)
Z 480 (Estlcam setting as recommended by V1)
Cutting Speeds:
X/Y 8mm/s (Estlcam tool setting)
Z 2mm/s (Estlcam tool setting)

Regarding the scaling issue:
A 1-3/8" (1.375") circle cuts out consistently as a 1.32" circle


Thanks again for the help






Can you update your estlcam and try again, there was a DXF scaling issue that was just fixed.

I was running the latest 64bit version

I did delete Estlcam from my PC and reinstalled it, I still get the inconsistent cutting. I also installed a pen and tried that using the engraving setting and I get the same result

I am going to try and draw an entire new rib section and try a different DXF of a totally different CAD file and see what happens


In trying to eliminate if the DXF is a valid file and being opened in Estlcam correctly, I did the following:

  • Generated a DXF with an alignment grid in the DXF.
  • Oopened the new DXF file in Estlcam.
The grid lines in the DXF line up exactly over the Estlcam grid lines in. With seeing the grid lines aligning, the DXF is indicating as opening and scaling correctly in Estlcam.

So there is either an issue in the generation of the G code or there is something (mechanical) causing the MPCNC rig to not to maintain the correct path when moving along the long axis (the X axis) from one end (origin end) to the other and then back to the origin end.


There is a sticky with some questions that will really help get this easier. Pictures of your build, endmill, build info, have you ran the crown, ect.

I put a pen in and ran another crown and it comes out good. I am getting start and stop mismatch on circles.

I did another print of a long rib section (a new dxf file of a totally different rib) using the pen instead of the spindle and I get the same issue where the start (origin) and stop (return to origin) points are off by 1/4".

I only notice this mismatch on the X axis. I will take another picture of that print and post it also.

I am thinking that there is something mechanically causing it in the X direction. This is the longer axis of 48".

I will also get pics of the build

Hi Ryan:

I am up and running like a top !
As I suspected it was a mechanical issue, I just could not find it immediately.
The cogged drive pulley on one of the X axis motors loosened up and was slipping on the stepper shaft, so just one X axis stepper was driving the gantry.
I found it when I disassembled the belts in route to check the squareness of the gantry.

I will be cutting ribs and fuselage formers all weekend for a new project.

All I can say is this is one awesome machine !

Thanks again for all the help and for the design of the MPCNC


1 Like


From now on my first response needs to be “check the pulleys”. No joke I almost scrapped the LR2 because a loose pulley was messing with me for the first day or two. I thought I messed up something in the design somehow.