I've tried everything - Endstop issue or Software?

Hello everyone, I need assistance and I’m running out of time available to work on this.

I can’t seem to successfully home the device correctly. All endstops have been wired NC, ran the M119 command, confirmed they’re open until “TRIGGERED”. I did the rectangle, Pythagoras theorem, figured out I was off 3.125mm. Moved a block a tooth to reduce it to 1.125mm, set my offsets in repetier using M666 X1 Y1, saved using M500. Tried to home it again and zero change. Z homes perfectly, can’t home X or Y.

So I updated the firmware, adjusted the offsets in the adv configuration file, saved, verified, flashed the new bios. Tried it again to no prevail.

My surface area is 490x490, technically bigger but I settled with that for now, z from zero can go 65mm. All steppers are working correctly, I can connect to the software just fine, lcd screen works, and like said previously all endstops read open until “Triggered”.

1 Like

So, homing works, but the M666 doesn’t?

X and Y are related in the squareness. I would try setting just one or the other, and not both. They may have basically canceled each other out, rotating the whole work surface by 1mm.

This is running RAMBo 1.4v, dual endstop btw

FIRMWARE: V1CNC_Rambo_Dual-2.0.7.2-src

M666 does work, I’ve confirmed this in my config.adv file. I’ve even changed this and uploaded via Arduino, I’ve tried through VSC.

I’ve tried one and the other, the issue I’ve ran into is the machine doesn’t go negative. I have my machine set up in the back left corner, where my LCD is. When I hit park in Repetier, it takes it to 245,245 (Center). I can hit home and it does return back but either X1 hits first or X2. Same for the Y as well. So I moved my stopper so that X1/Y1 hits first, moved the X2/Y2 stoppers within 1mm of the endstop, and then set the offset accordingly and it did nothing.

I took a video of it;

Fixed it!! Thank you for your help.

How did you fix it?